Multiple warning lights - BMW M5 Forum and M6 Forums
E63 BMW M6 Forum and BMW M6 Convertible | m6board.com 2005- Advertiser's Forum.

 1Likes
  • 1 Post By London_e63
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 8 Old 12th April 2019, 08:43 PM Thread Starter
London_e63
Junior Member, warming up (<31 posts)
 
Join Date: Apr 2019
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Multiple warning lights

Hi guys,

I'm new on here. I've had my e63 M6 about 2.5 years now, absolutely love it but its not proved to be the most reliable car.

At the moment it just randomly started displaying multiple error messages.

Flat tyre monitor failure
transmission fault
ABS fault
Start assistant inactive
Driving stability

Thinks that's about it. Has anyone experienced anything like this before? Im guessing these cant all have failed at the same time, well I hope so anyway!
London_e63 is online now  
Sponsored Links
Advertisement
 
post #2 of 8 Old 13th April 2019, 12:35 AM
psing23
Member, Sport: On DSC: Off
 
psing23's Avatar
 
Join Date: Jul 2012
Location: South Florida
Posts: 218
Thanks: 19
Thanked 11 Times in 11 Posts
Garage
Check the battery, voltage regulator, alternator etc. These cars are very sensitive in that regard.

Sent from my Moto Z (2) using Tapatalk

08 e63 M6 AW
02 e46 M3 TiAg - Track Toy
psing23 is offline  
post #3 of 8 Old 13th April 2019, 01:46 AM
v spec
Junior Member, warming up (<31 posts)
 
Join Date: Jun 2013
Location: Australia
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
v spec is offline  
 
post #4 of 8 Old 13th April 2019, 10:42 AM Thread Starter
London_e63
Junior Member, warming up (<31 posts)
 
Join Date: Apr 2019
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks.

What voltages am I looking for at the battery with the engine off and the engine running?
London_e63 is online now  
post #5 of 8 Old 13th April 2019, 04:36 PM
mubarak
Member, P500 Sport, DSC off (>900)
 
mubarak's Avatar
 
Join Date: Jan 2005
Location: QATAR
Posts: 907
Thanks: 6
Thanked 43 Times in 37 Posts
Garage
Quote:
Originally Posted by London_e63 View Post
Thanks.

What voltages am I looking for at the battery with the engine off and the engine running?
Search is your friends .

https://www.e90post.com/forums/showthread.php?t=794502
mubarak is online now  
post #6 of 8 Old 15th April 2019, 11:05 AM
Bimmer_Pilot
Member, Sport: On DSC: On (>100 posts)
 
Join Date: Jan 2018
Posts: 122
Thanks: 2
Thanked 6 Times in 6 Posts
Garage
Quote:
Originally Posted by London_e63 View Post
Hi guys,

I'm new on here. I've had my e63 M6 about 2.5 years now, absolutely love it but its not proved to be the most reliable car.

At the moment it just randomly started displaying multiple error messages.

Flat tyre monitor failure
transmission fault
ABS fault
Start assistant inactive
Driving stability

Thinks that's about it. Has anyone experienced anything like this before? Im guessing these cant all have failed at the same time, well I hope so anyway!
That sounds exactly like what happened when my battery started to die.
Bimmer_Pilot is offline  
post #7 of 8 Old 18th April 2019, 06:26 PM Thread Starter
London_e63
Junior Member, warming up (<31 posts)
 
Join Date: Apr 2019
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
I’m getting 12.1v with engine not running
Then 14.2v with the engine running. Does that seem about right?
London_e63 is online now  
post #8 of 8 Old 16th June 2019, 01:31 PM Thread Starter
London_e63
Junior Member, warming up (<31 posts)
 
Join Date: Apr 2019
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
So this was all caused by a faulty wheel speed sensor. Which was a cheap fix. Just in case anyone else has a similar issue in the future.
London_e63 is online now  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW M5 Forum and M6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Overhead lights "pulsing" at idle, idle appears steady but sounds like its pulsing in time to lights, thoughts? JoeFromPA E39 M5 and E52 Z8 Discussion 10 14th April 2014 10:54 PM
Installing Celis Tail Lights 1mpowerme E39 M5 and E52 Z8 Discussion 36 12th April 2009 01:55 PM
Done a search but too many warning lights to make sense. Envisage0 E39 M5 and E52 Z8 Discussion 9 20th May 2008 11:09 PM
Lights ON Warning Fails vadas1 E34 M5 Discussion 2 21st September 2003 01:43 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome