E64 Water in boot, Electrical Issues - BMW M5 Forum and M6 Forums
E63 BMW M6 Forum and BMW M6 Convertible | m6board.com 2005- Advertiser's Forum.

 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 4 Old 25th March 2019, 03:07 PM Thread Starter
Colby1knobi
Junior Member, warming up (<31 posts)
 
Join Date: Mar 2019
Location: Philadelphia, PA
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
E64 Water in boot, Electrical Issues

Hi Everyone- New to the 2007 and consequentially the forum.

2007 E64 M6 - 57K miles.

All was working great until last week when we had 2 days of heavy rain. There was water in the boot, below the battery compartment. I turkey basted about 40 Oz. out of the thing. Electrical issues started with the boot release not working from either the interior button or the Key FOB. Then the convertible top stopped working- nothing when I press either open or close button (I was going to see about unclogging the drains) - not even a light or error message. Yesterday, the rear window would go down, but not back up.

Every search I do comes up with the issue being the rear drains and how to remedy, however I haven't found anything about the associated electrical gremlins that impact the top operations. I assume all of these issues are related, but don't know where to even begin. Any thoughts? TIA

Colby
Colby1knobi is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 22nd April 2019, 11:49 PM Thread Starter
Colby1knobi
Junior Member, warming up (<31 posts)
 
Join Date: Mar 2019
Location: Philadelphia, PA
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Colby1knobi View Post
Hi Everyone- New to the 2007 and consequentially the forum.

2007 E64 M6 - 57K miles.

All was working great until last week when we had 2 days of heavy rain. There was water in the boot, below the battery compartment. I turkey basted about 40 Oz. out of the thing. Electrical issues started with the boot release not working from either the interior button or the Key FOB. Then the convertible top stopped working- nothing when I press either open or close button (I was going to see about unclogging the drains) - not even a light or error message. Yesterday, the rear window would go down, but not back up.

Every search I do comes up with the issue being the rear drains and how to remedy, however I haven't found anything about the associated electrical gremlins that impact the top operations. I assume all of these issues are related, but don't know where to even begin. Any thoughts? TIA

Colby
I am actually surprised there were no replies since this seems to be a common issue. For anyone else experiencing, I will provide my results.
Quite obviously an electrical issue.
Diagnose Codes:
**Autel MaxiDiag 805 code reader: A698 (Temperature Sensor: Invalid Signal), A692 (CVM: Supply. Hall Sensors Plug A output voltage too low), A699 (CVM: Rear-Window Drive), A693 (CVM: Supply, Hall Sensors, plug C output voltage too low).

Repairs completed:
First- Water test. Came back negative. There was no water infiltration seen after a few thorough soakings by the dealer. I did notice that the rear window rubber seal and the unrelated front windshield are in need of replacement. One of the drains in the top storage area was very slow draining, and another was not as great as it could be, so I cleared them all to free flowing.

Second: Convertible top control module was replaced. This fixed all of the issues immediately. ~$450 part new. The next day the trunk release stopped working again.

Lastly: Top convertible left latch replaced. ~$750 part. This fixed the issue with the trunk. No issues since.

Hopefully this helps someone out.
Colby1knobi is offline  
post #3 of 4 Old 26th April 2019, 04:24 AM
Junzie
Junior Member, warming up (<31 posts)
 
Junzie's Avatar
 
Join Date: Feb 2017
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks for sharing your findings, appreciate it. Hopefully i wont have to use it any time soon.
Junzie is offline  
 
post #4 of 4 Old 4th June 2019, 03:08 AM
terraforma
Junior Member, warming up (<31 posts)
 
Join Date: Jun 2019
Location: Los Angeles, CA
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
This happened to my e64 M6 this year (February 2019). $4903.25 in repairs + $660.88 for drain cleaning at BMW Beverly Hills. Luckily, the insurance covered the repairs, but after much back and forth and 2 months of down time for the car.
terraforma is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW M5 Forum and M6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange electrical issues w ctrl locks, windows, sunroof.. stija E34 M5 Discussion 35 7th May 2018 06:26 AM
Evans Waterless Coolant ? AseanAero E34 M5 Discussion 7 23rd January 2016 06:12 PM
Replica BMW E63 / E64 M6 side mirror NvdAutoSport M6 E63 Group Buy and Sponsor Discussion and Offerings 0 21st August 2014 06:52 AM
I'm stranded, please help, electrical issues! S4toM5 E39 M5 and E52 Z8 Discussion 12 6th June 2012 04:45 AM
Get ready to flame me...[DIY] palantirion E39 M5 and E52 Z8 Discussion 15 13th September 2008 08:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome