SMG Communication Error in ISTA? - BMW M5 Forum and M6 Forums
E60 M5 and E61 M5 Touring Discussion 2005- Advertiser's Forum

 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 8 Old 25th June 2019, 11:27 PM Thread Starter
Jdq5947
Junior Member, warming up (<31 posts)
 
Join Date: Jun 2019
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
SMG Communication Error in ISTA?

First post... been a stalker for almost a year since I purchased my M5

A little background before the real question. I recently got the red cog of death in my 06 with 74k miles on it. I had the car towed home and noticed a puddle of hydraulic oil under the car. I pulled everything apart and it turned out to be the slave cylinder but while i was in there i replaced the clutch, clutch position, etc.... Everything that has been recommended by this forum to replace when you have to pull the transmission anyway. Everything went very smooth mechanically, when I went to do the adaptation in ISTA is where I am having my issue. I did not bleed the slave cylinder before starting the adaptation so it failed, as expected but now I am getting this SMG communication error in ISTA. So now if i go into service functions and try to bleed off the system to do a fluid check it just sits there with the spinning hour glass and does not reduce the pressure. I then get an error in a pop up window that says "The communication with the control unit SMG has been disrupted. The ignition must be switched on or the PAD mode activated." The key has been in the on position the whole time, so it is not that. Has anyone had this error before? Did i somehow brick the SMG control module? Any help would be greatly appreciated

Also if anyone is curious the current fault codes are 4f66, 4f67, 5506
Jdq5947 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 25th June 2019, 11:44 PM
flacoramos
m5board.comoholic (>1000 posts)
 
Join Date: Jan 2017
Location: IL
Posts: 1,181
Thanks: 4
Thanked 95 Times in 93 Posts
flacoramos is offline  
post #3 of 8 Old 26th June 2019, 01:52 AM Thread Starter
Jdq5947
Junior Member, warming up (<31 posts)
 
Join Date: Jun 2019
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Just tried INPA and got a pop up error "MOTOR aus", translated engine off.... Now i am really confused. Both pieces of software are pointing to the key being in the off position which is not the case.

I also have constant gongs with clutch adaptation active on the idrive. the gongs continue after the start button is pushed and the key is removed. It does eventually stop
Jdq5947 is offline  
 
post #4 of 8 Old 26th June 2019, 12:56 PM
Ferris
m5board.comoholic (>1000 posts)
 
Join Date: Dec 2012
Location: New Jersey
Posts: 1,344
Thanks: 4
Thanked 129 Times in 118 Posts
Are you sure you the popup was an error or was it telling it you to shut the engine off? Inpa tells you when it wants the engine on or off during the process. I never used ISTA so I can't help you there.

What state are you in? Since summer is here I took a break from the SMG tuning project, rather spend time on water than on land, and as such I can lend you one of my spare SMG computers to try.

2001 E36/7 MRoadster
2001 E39 M5
2010 E60 M5
2008 E90 335xi
Ferris is offline  
post #5 of 8 Old 26th June 2019, 02:53 PM Thread Starter
Jdq5947
Junior Member, warming up (<31 posts)
 
Join Date: Jun 2019
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
The more I thought about it last night you are probably correct, It was probably making sure the engine was not running. I have never used INPA for this so it made me jump to that conclusion. Once i click ok on the pop up window in INPA it starts the process but eventually faults out with an SMG communication error as well. I did not write down the complete error message but I will look when i get home. I am located in NY, finger lakes region specifically. I do not blame you for wanting to be on the water it has finally stopped raining here and the weather has warmed up enough to get out on the lakes.
Jdq5947 is offline  
post #6 of 8 Old 26th June 2019, 03:02 PM
Ferris
m5board.comoholic (>1000 posts)
 
Join Date: Dec 2012
Location: New Jersey
Posts: 1,344
Thanks: 4
Thanked 129 Times in 118 Posts
Communication faults are risky issues, what's reporting it? Are other modules reporting errors? ie is the DME/DSC not able to communicate.

Ok well the offer to lend you a SMG TCU, feel free to pm and we'll work details. Let us know either way if you get it...

I drive up to Rochester to meet with a client every now and then, finger lakes are nice region.

2001 E36/7 MRoadster
2001 E39 M5
2010 E60 M5
2008 E90 335xi
Ferris is offline  
post #7 of 8 Old 27th June 2019, 03:37 AM Thread Starter
Jdq5947
Junior Member, warming up (<31 posts)
 
Join Date: Jun 2019
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Tried to PM you but I am not allowed to do to not having enough posts. I would like to take you up on the offer.

I am not sure what else this could be... any other thoughts?
Jdq5947 is offline  
post #8 of 8 Old 27th June 2019, 01:05 PM
Ferris
m5board.comoholic (>1000 posts)
 
Join Date: Dec 2012
Location: New Jersey
Posts: 1,344
Thanks: 4
Thanked 129 Times in 118 Posts
Quote:
Originally Posted by Jdq5947 View Post
Tried to PM you but I am not allowed to do to not having enough posts. I would like to take you up on the offer.

I am not sure what else this could be... any other thoughts?
write me at chris.laganga - gmail

2001 E36/7 MRoadster
2001 E39 M5
2010 E60 M5
2008 E90 335xi
Ferris is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW M5 Forum and M6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 2 (1 members and 1 guests)
Panacea151
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome