27b6 camshaft control inlet bank 2 output stage fault code - BMW M5 Forum and M6 Forums
E60 M5 and E61 M5 Touring Discussion 2005- Advertiser's Forum

 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 5 Old 15th January 2018, 02:14 PM Thread Starter
Matty.13
Junior Member, warming up (<31 posts)
 
Join Date: Dec 2016
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
27b6 camshaft control inlet bank 2 output stage fault code

Hi guys
I hope one of you might be able to help . My car keeps throwing up this fault code .
The car runs fine and does not throw engine management light. I replaced one of the sensors on this bank with one I had knocking about .
Am I right in thinking there are 2 camshaft sensors per bank?
Also my car in a uk car so bank 2 is the passenger side ?
When the weather gets better I plan on swapping one sides sensors to the other and see if I still get the same fault , in the mean time is this anything to worry about ?
Any advice is greatly appreciated


Sent from my iPhone using Tapatalk
Matty.13 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 24th January 2018, 06:53 PM
nizoo_k
Junior Member, warming up (<31 posts)
 
Join Date: Jan 2018
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
i have the same code "27B6" on my 2007 M6. the car drives just fine, altough the CEL is on, waiting on a friend of mine to get the solenoids test via INPA software....
does your car have a rattling noise coming from your vanos area?
nizoo_k is offline  
post #3 of 5 Old 24th January 2018, 08:09 PM Thread Starter
Matty.13
Junior Member, warming up (<31 posts)
 
Join Date: Dec 2016
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
No it does not rattle at all . It’s quite strange as the code has not appeared the last time couple of times I have driven the car. Please post if you get any answers . I will be taking my car to a diagnostic expect next month just as a precaution to make sure nothing is wrong .


Sent from my iPhone using Tapatalk
Matty.13 is offline  
 
post #4 of 5 Old 27th January 2018, 03:05 AM
jcolley
M5 Expert (>4000)
 
jcolley's Avatar
 
Join Date: Apr 2006
Location: Maine
Posts: 5,650
Thanks: 77
Thanked 1,264 Times in 872 Posts
That would almost seem to me to indicate a problem in either the wiring going to the solenoid or the h-bridge that's driving the solenoid inside the DME.
jcolley is offline  
The Following User Says Thank You to jcolley For This Useful Post:
Matty.13 (27th January 2018)
post #5 of 5 Old 27th January 2018, 01:07 PM Thread Starter
Matty.13
Junior Member, warming up (<31 posts)
 
Join Date: Dec 2016
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
Matty.13 is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW M5 Forum and M6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
SMG Fault Code 4F21 Transmission Control internal fault (estate) GBNETWORK E63 BMW M6 Forum and BMW M6 Convertible | m6board.com 13 18th June 2018 08:30 PM
DIY: My Experience and Input in Replacing the Inlet Bank 1 (U.S. Passenger Side) CPS Camshaft Position Sensor blks4 E39 M5 and E52 Z8 Discussion 7 14th October 2011 10:09 AM
07/D4 - Signal, camshaft sensor, inlet, bank 1 blks4 E39 M5 and E52 Z8 Discussion 6 8th August 2011 01:16 AM
27BE vanos control bank 2 fault?? jamiepeers E63 BMW M6 Forum and BMW M6 Convertible | m6board.com 0 6th August 2010 01:30 PM
Code b9 "Exhaust Camshaft 1Vanos Position Control murph550 E39 M5 and E52 Z8 Discussion 3 28th January 2009 03:02 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome