Secondary air pump error - Page 2 - BMW M5 Forum and M6 Forums
E60 M5 and E61 M5 Touring Discussion 2005- Advertiser's Forum

Reply
 
LinkBack Thread Tools Rate Thread Display Modes
post #11 of 17 Old 5th October 2016, 08:33 PM
jcolley
M5 Expert (>4000)
 
jcolley's Avatar
 
Join Date: Apr 2006
Location: Maine
Posts: 5,660
Thanks: 77
Thanked 1,264 Times in 872 Posts
jcolley is offline  
Sponsored Links
Advertisement
 
post #12 of 17 Old 5th October 2016, 09:15 PM Thread Starter
minim
Member
 
Join Date: May 2016
Location: Norway
Posts: 48
Thanks: 1
Thanked 2 Times in 2 Posts
Garage
Thank you Jcolley. Those steps looks pretty similar to the steps that ISTA-D had me go through. The fourth one what is that supposed to mean "If secondary air pump" ? I never get the MIL light showing tho and the pump is running for sure. If you look at the first picture in the test it is showing 29kg/h (first post) on the sensor and I can hear the pump starting once I start the test. However when I try to start the car with this monitor up I cannot get a reading of how much air is going there. Almost like it's disabled in some sort? Can this be coded out and thats the reason I get the message? I'd really like the system coded back in so I get it working as designed again.

Can I read out those variable names with tool32 from the MS_S65_2 ECU btw? If so I could try to arrange so I poll those values just to have a look at it. I should however figure out if the system is triggering the pump signal at all. It doesn't seem like it.

Edit: reading through the triggers for the error once more I noticed that high lambda could throw this code. It doesn't say what "high lambda" is tho. Could this be causing it maybe? Would think that it should throw some kind of code on the lambda sensors to? I know they look normal with a hot engine but I've never tried measuring during startup. I thought it would just show crappy values in the start (and that the DME didn't use lambda before the engine was at operating temperature).

Edit2: I noticed that my DME is flashed in 2013 and most of the other parts of the car is flashed back when it was new in 04-05. Could this indicate some kind of tuning software that could be the reason why this is disabled?

Last edited by minim; 5th October 2016 at 10:25 PM.
minim is offline  
post #13 of 17 Old 18th October 2016, 02:43 PM
M5Ottawa
Member
 
Join Date: Oct 2015
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Secondary air system

Any more results on this ? I'm having similar code issues and wondered if you were able to track down the problem ?


Thanks,
M5Ottawa is offline  
 
post #14 of 17 Old 19th October 2016, 01:11 AM
cold m3
Member, P500, DSC On (>600)
 
cold m3's Avatar
 
Join Date: Jun 2014
Location: SE Pa
Posts: 650
Thanks: 10
Thanked 35 Times in 34 Posts
Garage
Curious why any performance oriented driver would want a SAP in their car?

Cant wait to remove mine!

Current: 6MT 2008 LCI E60 M5 (Interlagos Blue)
Last: 6MT Super Charged E46 M3 (Carbon Black) (6 years of ownership)
Instagram: Cold_M3
Photos of My ///M5
cold m3 is offline  
post #15 of 17 Old 19th October 2016, 02:33 AM
jcolley
M5 Expert (>4000)
 
jcolley's Avatar
 
Join Date: Apr 2006
Location: Maine
Posts: 5,660
Thanks: 77
Thanked 1,264 Times in 872 Posts
Quote:
Originally Posted by cold m3 View Post
Curious why any performance oriented driver would want a SAP in their car?

Cant wait to remove mine!
Emissions compliance, that's it. There's a huge amount of real estate on the E6x M cars that could be freed up, I've been waiting for someone to ask about deleting. If you don't have a tune yet, I can disable the SAP subroutine as well as the error codes for a "off-road use" car.
jcolley is offline  
post #16 of 17 Old 19th October 2016, 02:53 AM
cold m3
Member, P500, DSC On (>600)
 
cold m3's Avatar
 
Join Date: Jun 2014
Location: SE Pa
Posts: 650
Thanks: 10
Thanked 35 Times in 34 Posts
Garage
Quote:
Originally Posted by jcolley View Post
Emissions compliance, that's it. There's a huge amount of real estate on the E6x M cars that could be freed up, I've been waiting for someone to ask about deleting. If you don't have a tune yet, I can disable the SAP subroutine as well as the error codes for a "off-road use" car.
I 100% plan on removing all of it. Both pumps / all tubes and hardware. and obviously need it to be in the 'ready' state not just a CEL removal.

I want a tune for other features as well and have considered yours (FAM). Kinda waiting for the deals to show up for xmas...

Current: 6MT 2008 LCI E60 M5 (Interlagos Blue)
Last: 6MT Super Charged E46 M3 (Carbon Black) (6 years of ownership)
Instagram: Cold_M3
Photos of My ///M5
cold m3 is offline  
post #17 of 17 Old 19th October 2016, 06:16 AM Thread Starter
minim
Member
 
Join Date: May 2016
Location: Norway
Posts: 48
Thanks: 1
Thanked 2 Times in 2 Posts
Garage
I just assumed that it was disabled with the DME Flash that was done in 2013 and that it should be like this with the current Flash. So didn't bother more with it ^^
minim is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW M5 Forum and M6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
E39 For Sale: Secondary Air Pump mattmor Parts / Other For Sale or Wanted 2 4th November 2012 10:59 PM
Secondary air pump JustinM5 E39 M5 and E52 Z8 Discussion 39 13th June 2012 07:27 PM
Secondary air pump code still comes up after replacing the pump.. greekspeed E39 M5 and E52 Z8 Discussion 23 28th February 2011 02:47 PM
New pre cat 02 sensors, secondary air pump, mafs, fuel pump and filter = 1 happy S2!! madyspop E39 M5 and E52 Z8 Discussion 0 12th February 2011 04:37 AM
Troubleshooting error p0170, wrong course secondary air? flamex10 E39 M5 and E52 Z8 Discussion 3 21st November 2006 09:47 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome