27AA and 27AB codes after O2 sensor replacement and many other issues - Page 6 - BMW M5 Forum and M6 Forums
E60 M5 and E61 M5 Touring Discussion 2005- Advertiser's Forum

 1Likes
Reply
 
LinkBack Thread Tools Rate Thread Display Modes
post #51 of 55 Old 12th February 2018, 12:26 AM
Sophie
Member, Sport: On DSC: Off
 
Join Date: Mar 2013
Location: Plano, TX
Posts: 226
Thanks: 24
Thanked 33 Times in 27 Posts
Quote:
Originally Posted by kei03174 View Post
Digging up a dead thread, but I am experiencing a similar problem.
I dont know what is happening to her EGR, but she keeps throwing me emission light.
I got 27aa for only on bank 1.
Does anyone on this thread with a similar experience have solved their issues?
then How?

Throttle Actuator you said, Sophie,
How did you ended up changing that even if the code you only get was O2 sensor over the limit...
that does not ring any bell in my head...
It is actually pretty straightforward. Throttle body actuator's malfunction affects throttle openings and can definitely cause misfires if not enough oxygen is allowed to come in when needed.
Sophie is offline  
Sponsored Links
Advertisement
 
post #52 of 55 Old 12th February 2018, 12:34 AM
Awbimmer
Fellow Member (>400)
 
Join Date: Mar 2016
Posts: 403
Thanks: 4
Thanked 13 Times in 13 Posts
Quote:
Originally Posted by kei03174 View Post
Awbimmer, sir.
Did you ended up fixing this issue?
I have an exact problem only on bank 1. I am narrowing down the cause...
Hey
No as I haven't done the smoke test and since October 2017 I've driven the car just 400 odd miles so I'm not really too concerned right now. I'll get this done before the summer though with the aforementioned steps of action... for now I'm doing up my e34 525i.

Just put them on springs and bought a genuine set of hartge split rims.

I have more enjoyment daily driving my e34 bmw over the m6 lol.

Sent from my SM-G950F using Tapatalk
Awbimmer is offline  
post #53 of 55 Old 12th February 2018, 07:24 PM
kei03174
Member, Sport: Off DSC: On (>50 posts)
 
Join Date: May 2017
Posts: 64
Thanks: 3
Thanked 1 Time in 1 Post
Quote:
Originally Posted by Sophie View Post
It is actually pretty straightforward. Throttle body actuator's malfunction affects throttle openings and can definitely cause misfires if not enough oxygen is allowed to come in when needed.
I may have confused you,
I don't have a code for throttle actuator. only Emission Light with the code 27aa O2 sensor limit pre-cat on bank 1.
does this code a precursor to the failure of actuator?

Last edited by kei03174; 12th February 2018 at 07:24 PM.
kei03174 is offline  
 
post #54 of 55 Old 12th February 2018, 07:29 PM
kei03174
Member, Sport: Off DSC: On (>50 posts)
 
Join Date: May 2017
Posts: 64
Thanks: 3
Thanked 1 Time in 1 Post
Quote:
Originally Posted by grahame39m5 View Post
Sophie , I'm having the 27AB code after replacing both sensors. I'm £600 worse off and bmw still don't know why the fault keeps coming back. My code only happens on tick over, never ever while driving. I'm pulling my hair out here! Can you shed any light on this?

Bmw have smoke tested the intake and exhaust manifolds but found no leaks

Car is a 2007 e64 M6
Thanks, Graham
What kind of problems with the batch of production in 2007 for the e64 m6? idk
I am experiencing a same problem with you grahame39m5.
although mine is only on bank 1 27aa.
did you by any chance figured the source of problem?
my car now threw me a Emission light on every cold start.
Look at the actual positions between bank 1 and bank 2 of idle actuators.
Do you have a similar readings as mine does?
https://youtu.be/qNpxqpYnxO8

If you can, post your readings that can benefit other members with this problem in future.

Last edited by kei03174; 12th February 2018 at 07:32 PM.
kei03174 is offline  
post #55 of 55 Old 13th February 2018, 06:41 PM
Sophie
Member, Sport: On DSC: Off
 
Join Date: Mar 2013
Location: Plano, TX
Posts: 226
Thanks: 24
Thanked 33 Times in 27 Posts
Quote:
Originally Posted by kei03174 View Post
I may have confused you,
I don't have a code for throttle actuator. only Emission Light with the code 27aa O2 sensor limit pre-cat on bank 1.
does this code a precursor to the failure of actuator?
Yes, I know what exactly you meant. At least based on my experience(I did not have error codes directly related to throttle actuator either), replacing actuators solved the fault codes I have around O2 sensors. I did replace O2 sensors before that and that did not help, which made me believe it is logical to think that actuator issue can cause O2 sensor to flag faults. Or in your words, O2 sensor faults can be an early indicator of actuator failures.
Sophie is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW M5 Forum and M6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with INPA O2 sensor codes please. Minty E39 M5 and E52 Z8 Discussion 17 22nd July 2013 10:18 AM
2 Error Codes (Crankshaft and Camshaft Position Sensor Bank 2 Sensor B) cpatzer E39 M5 and E52 Z8 Discussion 11 27th December 2009 08:08 AM
Engine codes O2 Sensor shamus_mcd E39 M5 and E52 Z8 Discussion 2 22nd November 2009 02:45 AM
Ambient tempature issues even after sensor replacement beast27 E39 M5 and E52 Z8 Discussion 14 19th October 2007 10:34 AM
0D and AE Codes: Replace O2 sensor? lemansmiami E39 M5 and E52 Z8 Discussion 2 6th March 2007 12:38 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome