O2 sensor help - BMW M5 Forum and M6 Forums
E39 M5 and E52 Z8 Discussion 1998-2003 Advertiser's Forum

 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 6 Old 13th June 2019, 09:17 PM Thread Starter
cal45fan
Member, Sport: Off DSC: On (>50 posts)
 
Join Date: Mar 2011
Location: Mesa, AZ
Posts: 69
Thanks: 1
Thanked 0 Times in 0 Posts
O2 sensor help

I have been chasing a bank 1, sensor 2 pre-heater circuit inop. I checked the fuses by the DME and O2 sensor is new.

I am suspecting a break in the wiring.

Where are the wires leading to from the 02 sensor?


Sent from my iPhone using Tapatalk
cal45fan is online now  
Sponsored Links
Advertisement
 
post #2 of 6 Old 14th June 2019, 01:38 AM
BWM
Addicted Member (>300 posts)
 
Join Date: May 2018
Location: TN
Posts: 340
Thanks: 33
Thanked 37 Times in 33 Posts
Quote:
Originally Posted by cal45fan View Post
I have been chasing a bank 1, sensor 2 pre-heater circuit inop. I checked the fuses by the DME and O2 sensor is new.

I am suspecting a break in the wiring.

Where are the wires leading to from the 02 sensor?


Sent from my iPhone using Tapatalk
Having recently done rear main seal I've had everything off and I remember how they run under the heat shield and then I think around tranny? Maybe start in that area since they're close to hot exhaust.
Also, have you removed plastic cover over wiring junction where they connect to car wiring to see if everything looks ok there?

Last edited by BWM; 14th June 2019 at 01:40 AM.
BWM is offline  
post #3 of 6 Old 14th June 2019, 03:36 AM Thread Starter
cal45fan
Member, Sport: Off DSC: On (>50 posts)
 
Join Date: Mar 2011
Location: Mesa, AZ
Posts: 69
Thanks: 1
Thanked 0 Times in 0 Posts
I guess I am trying to determine if it ends where the DME is so I can do a continuity test from connector to connector.


Sent from my iPhone using Tapatalk
cal45fan is online now  
 
post #4 of 6 Old 14th June 2019, 04:47 AM
Rosie
Member, Sport: Off DSC: On (>50 posts)
 
Join Date: Nov 2017
Location: Sydney
Posts: 81
Thanks: 3
Thanked 25 Times in 22 Posts
Quote:
Originally Posted by cal45fan View Post
I guess I am trying to determine if it ends where the DME is so I can do a continuity test from connector to connector.


Sent from my iPhone using Tapatalk


Yes they/it does.
Module plug 2 at the DME.



https://www.newtis.info/tisv2/a/en/e...ensors/wKx8rco
Rosie is online now  
The Following User Says Thank You to Rosie For This Useful Post:
gsfent (14th June 2019)
post #5 of 6 Old 16th June 2019, 08:04 AM Thread Starter
cal45fan
Member, Sport: Off DSC: On (>50 posts)
 
Join Date: Mar 2011
Location: Mesa, AZ
Posts: 69
Thanks: 1
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Rosie View Post
Yes they/it does.
Module plug 2 at the DME.



https://www.newtis.info/tisv2/a/en/e...ensors/wKx8rco


Rosie, thank you. Your response is a great help! I found the issue. All 4 wires fused together so I spliced it properly. Hi


Sent from my iPhone using Tapatalk
cal45fan is online now  
post #6 of 6 Old 16th June 2019, 08:13 AM
Rosie
Member, Sport: Off DSC: On (>50 posts)
 
Join Date: Nov 2017
Location: Sydney
Posts: 81
Thanks: 3
Thanked 25 Times in 22 Posts
Quote:
Originally Posted by cal45fan View Post
Rosie, thank you. Your response is a great help! I found the issue. All 4 wires fused together so I spliced it properly. Hi


Sent from my iPhone using Tapatalk


No probs,
However, if the wiring has been hot enough to melt the insulation, I’d be checking the internal resistance of the O2 sensor for an internal short.
Rosie is online now  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW M5 Forum and M6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome