Avin Avant-4 E39 Installation & Experience - BMW M5 Forum and M6 Forums
E39 M5 and E52 Z8 Discussion 1998-2003 Advertiser's Forum

Reply
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 14 Unread 13th June 2019, 12:17 AM Thread Starter
[email protected]
Junior Member, warming up (<31 posts)
 
Join Date: May 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Avin Avant-4 E39 Installation & Experience

I finally found my dream E39 M5 a few months ago - it's a delight! Well, except for the nav/radio unit and screen. So, I decided to upgrade. I bypassed the many Chinese units on eBay in favor of the Avin Avant-4 unit and have no regrets. Here's a brief report.

I ordered the unit, wireless backup camera, wireless external TPMS, Apple CarPlay, etc. for my car system which already had BMW nav and DSP amp. It came soon, boxed nicely with a lot of stuff. Their website (www.avinusa.com) shows everything. I used a video showing how to install and wire for my E39. It wasn't perfect, but got the job done. Very helpful was another video in the M3 Forum.

The Avant-4 is impressive. Rather than describe all of it here, just see their website. It fits the E39 dash perfectly, looks like built-in, and works flawlessly. Installation is not easy, but it's very doable to those who like upgrade projects and have some time to get it done.

Unfortunately, the instructions are miserable, and customer support is spotty. Once installed, I had to go to a number of videos and procedures and download and install various apps to get the various options working, but they are working with one important exception - no sound on my car system. That's a biggie, and it's something others have experienced. Hopefully Avin will help me resolve it soon.

Anyway, overall, it's a worthwhile upgrade. My cost with all the bells and whistles was around $850. Certainly not cheap, but it gives a lot.
Sponsored Links
Advertisement
 
post #2 of 14 Unread 13th June 2019, 12:50 AM
mgdmb
M5 Guru (>2000 posts)
 
mgdmb's Avatar
 
Join Date: Feb 2007
Location: Campbell, CA
Posts: 3,586
Thanks: 280
Thanked 517 Times in 472 Posts
You need to activate the iBus license so DSP works. Send your VIN to Avin support, and to the iBus devs

If you've done that, you need to set the DSP to mid_basis
mgdmb is offline  
post #3 of 14 Unread 13th June 2019, 01:54 AM Thread Starter
[email protected]
Junior Member, warming up (<31 posts)
 
Join Date: May 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Yes, my IBUS BMW is active and car unlocked. The DSP amp is set to mid level. Still no sound. Everything else works well. Any additional ideas appreciated,
 
post #4 of 14 Unread 14th June 2019, 02:30 AM
mgdmb
M5 Guru (>2000 posts)
 
mgdmb's Avatar
 
Join Date: Feb 2007
Location: Campbell, CA
Posts: 3,586
Thanks: 280
Thanked 517 Times in 472 Posts
Can try doing a reset and recoding it to mid_basis and setting the polling to inactive, but if the DSP amp worked before the install it should work now, assuming everything is installed correctly. I know Tommy (aka Avin support / Avin owner) can be really hard to get ahold of though...

https://wiki.ibus-app.de/index.php?t...iter_nutzen%3F
mgdmb is offline  
post #5 of 14 Unread 14th June 2019, 04:37 PM
Elahmad
Junior Member, warming up (<31 posts)
 
Join Date: Jan 2018
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
I did the EONON system all in with apple carplay for $360 didn't get to do wireless backup camera yet how'd that all go?
Elahmad is offline  
post #6 of 14 Unread 15th June 2019, 03:21 AM
ojomo
Junior Member, warming up (<31 posts)
 
Join Date: Jan 2018
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
I had an avant 2. It broke after a year, sent back for repairs, came back broke. Hope you don't have the same experience, went with an Xtron and its been perfect with a malaysk rom and rezler interface with ibus app.
ojomo is offline  
post #7 of 14 Unread 11th July 2019, 10:42 PM
Hud1086
Junior Member, warming up (<31 posts)
 
Join Date: Jun 2019
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
Quote:
Originally Posted by Elahmad View Post
I did the EONON system all in with apple carplay for $360 didn't get to do wireless backup camera yet how'd that all go?
How has your experience been with this? Any problems? I am looking at this, and installing a wireless apple carplay adapter. It's definitely cheaper than the Avin unit...
Hud1086 is online now  
post #8 of 14 Unread 13th July 2019, 08:27 AM
navarrojiii
Junior Member, warming up (<31 posts)
 
Join Date: Apr 2019
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by [email protected] View Post
I finally found my dream E39 M5 a few months ago - it's a delight! Well, except for the nav/radio unit and screen. So, I decided to upgrade. I bypassed the many Chinese units on eBay in favor of the Avin Avant-4 unit and have no regrets. Here's a brief report.

I ordered the unit, wireless backup camera, wireless external TPMS, Apple CarPlay, etc. for my car system which already had BMW nav and DSP amp. It came soon, boxed nicely with a lot of stuff. Their website (www.avinusa.com) shows everything. I used a video showing how to install and wire for my E39. It wasn't perfect, but got the job done. Very helpful was another video in the M3 Forum.

The Avant-4 is impressive. Rather than describe all of it here, just see their website. It fits the E39 dash perfectly, looks like built-in, and works flawlessly. Installation is not easy, but it's very doable to those who like upgrade projects and have some time to get it done.

Unfortunately, the instructions are miserable, and customer support is spotty. Once installed, I had to go to a number of videos and procedures and download and install various apps to get the various options working, but they are working with one important exception - no sound on my car system. That's a biggie, and it's something others have experienced. Hopefully Avin will help me resolve it soon.

Anyway, overall, it's a worthwhile upgrade. My cost with all the bells and whistles was around $850. Certainly not cheap, but it gives a lot.
Iím sorry about the issues youíre having. Iím about to pull the trigger myself on the Avant 4 so please keep us posted. Can I ask you how you ran your cable to the rear as in what path did you take? What was the most difficult part overall?
navarrojiii is offline  
post #9 of 14 Unread Yesterday, 06:48 PM
Haywood
Member
 
Join Date: Jul 2018
Posts: 35
Thanks: 2
Thanked 0 Times in 0 Posts
Garage
Quote:
Originally Posted by [email protected] View Post
I finally found my dream E39 M5 a few months ago - it's a delight! Well, except for the nav/radio unit and screen. So, I decided to upgrade. I bypassed the many Chinese units on eBay in favor of the Avin Avant-4 unit and have no regrets. Here's a brief report.

I ordered the unit, wireless backup camera, wireless external TPMS, Apple CarPlay, etc. for my car system which already had BMW nav and DSP amp. It came soon, boxed nicely with a lot of stuff. Their website (www.avinusa.com) shows everything. I used a video showing how to install and wire for my E39. It wasn't perfect, but got the job done. Very helpful was another video in the M3 Forum.

The Avant-4 is impressive. Rather than describe all of it here, just see their website. It fits the E39 dash perfectly, looks like built-in, and works flawlessly. Installation is not easy, but it's very doable to those who like upgrade projects and have some time to get it done.

Unfortunately, the instructions are miserable, and customer support is spotty. Once installed, I had to go to a number of videos and procedures and download and install various apps to get the various options working, but they are working with one important exception - no sound on my car system. That's a biggie, and it's something others have experienced. Hopefully Avin will help me resolve it soon.

Anyway, overall, it's a worthwhile upgrade. My cost with all the bells and whistles was around $850. Certainly not cheap, but it gives a lot.
That seems like a lot. I priced out the Alpine ILX-650, amp, backup camera, and XM receiver for $765 on Crutchfield. Did you ever look at this option?

2003 LMB e39 M5
1997 AW e36 M3

Last edited by Haywood; Yesterday at 06:50 PM.
Haywood is online now  
post #10 of 14 Unread Today, 02:49 PM
Obioban
M5 Guru (>2000 posts)
 
Obioban's Avatar
 
Join Date: May 2005
Location: Malvern, PA
Posts: 2,166
Thanks: 5
Thanked 180 Times in 160 Posts
Quote:
Originally Posted by Haywood View Post
That seems like a lot. I priced out the Alpine ILX-650, amp, backup camera, and XM receiver for $765 on Crutchfield. Did you ever look at this option?
Looks like crap/blatantly aftermarket installed.
Obioban is online now  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW M5 Forum and M6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 4 (3 members and 1 guests)
Obioban , qwkteg125 , Haywood



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome