Help identify what's missing - Xtron nav unit removal, back to OEM - Page 3 - BMW M5 Forum and M6 Forums
E39 M5 and E52 Z8 Discussion 1998-2003 Advertiser's Forum

 2Likes
Reply
 
LinkBack Thread Tools Rate Thread Display Modes
post #21 of 28 Old 9th May 2019, 01:00 PM
Marcel RSD
Addicted Member (>300 posts)
 
Marcel RSD's Avatar
 
Join Date: Mar 2012
Location: Netherlands
Posts: 368
Thanks: 11
Thanked 62 Times in 55 Posts
If the back light is on in the monitor, you are not getting a video signal. Can it be that this navigation unit is from a e46 with arrow navigation and you need to re-code it to 16:9 monitor ? If there is no external video module, I assume will not have a (correct) video signal.

Done so far:
- Evolve ECU tune, Alpha-N, sec. air pump delete, oct. 98, speed limiter removal
- Evolve carbon air intakes
- Evolve IATS relocate
- Evolve Medusa Headers
- Evolve 200 cell cats

And of course very happy with these mods
Marcel RSD is offline  
Sponsored Links
Advertisement
 
post #22 of 28 Old 9th May 2019, 01:05 PM Thread Starter
lockeed
Member, Sport: Off DSC: On (>50 posts)
 
lockeed's Avatar
 
Join Date: Jan 2018
Location: Quebec
Posts: 83
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
lockeed is online now  
post #23 of 28 Old 9th May 2019, 01:33 PM
Marcel RSD
Addicted Member (>300 posts)
 
Marcel RSD's Avatar
 
Join Date: Mar 2012
Location: Netherlands
Posts: 368
Thanks: 11
Thanked 62 Times in 55 Posts
Is your MKIII unit coded for e39 wide-screen or small screen or is it from an e46 and coded for arrow navigation ?
If it is coded for arrow navigation, you will not have a correct video output which is causing a "black screen".


You can try NAVCODER to see how it is coded.

Done so far:
- Evolve ECU tune, Alpha-N, sec. air pump delete, oct. 98, speed limiter removal
- Evolve carbon air intakes
- Evolve IATS relocate
- Evolve Medusa Headers
- Evolve 200 cell cats

And of course very happy with these mods

Last edited by Marcel RSD; 9th May 2019 at 01:34 PM.
Marcel RSD is offline  
 
post #24 of 28 Old 9th May 2019, 02:43 PM Thread Starter
lockeed
Member, Sport: Off DSC: On (>50 posts)
 
lockeed's Avatar
 
Join Date: Jan 2018
Location: Quebec
Posts: 83
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
I'm sure it's the OEM one.

The previous owner installed the Xtron because the screen went dark, didn't do anything to diagnose it...

01' M5 Silver
08' M3 Sedan white
02' M3 Coupe Silver
lockeed is online now  
post #25 of 28 Old 9th May 2019, 03:20 PM
Marcel RSD
Addicted Member (>300 posts)
 
Marcel RSD's Avatar
 
Join Date: Mar 2012
Location: Netherlands
Posts: 368
Thanks: 11
Thanked 62 Times in 55 Posts
If it is the original unit which was installed then the best solution is to try a unit from somebody else. I think the video board is toasted/defect in the navigation unit.

Done so far:
- Evolve ECU tune, Alpha-N, sec. air pump delete, oct. 98, speed limiter removal
- Evolve carbon air intakes
- Evolve IATS relocate
- Evolve Medusa Headers
- Evolve 200 cell cats

And of course very happy with these mods
Marcel RSD is offline  
post #26 of 28 Old 9th May 2019, 04:12 PM Thread Starter
lockeed
Member, Sport: Off DSC: On (>50 posts)
 
lockeed's Avatar
 
Join Date: Jan 2018
Location: Quebec
Posts: 83
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
Yup, that's exactly what i'm gonna do. There's an MKIII unit on the way which Chris helped me out with.

01' M5 Silver
08' M3 Sedan white
02' M3 Coupe Silver
lockeed is online now  
post #27 of 28 Old 19th May 2019, 04:11 PM Thread Starter
lockeed
Member, Sport: Off DSC: On (>50 posts)
 
lockeed's Avatar
 
Join Date: Jan 2018
Location: Quebec
Posts: 83
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
Quick update. The replacement nav unit solved the blank screen problem. Works like a charm.

Now I found out the cd changer was empty and the 6cd cartridge is missing.... I'll need to find a 6 cd cartridge or some sort of MP3 player or hdd that would take the charger's place and connect to the system. I think I've seen that somewhere....

01' M5 Silver
08' M3 Sedan white
02' M3 Coupe Silver
lockeed is online now  
post #28 of 28 Old 20th May 2019, 12:46 PM
Marcel RSD
Addicted Member (>300 posts)
 
Marcel RSD's Avatar
 
Join Date: Mar 2012
Location: Netherlands
Posts: 368
Thanks: 11
Thanked 62 Times in 55 Posts
I have the CP600BMW as CD emulator and does a terrific job playing MP3 with tags to the monitor. But you can also use GROM or get your hand on an OEM Alpine MP3 player.

Done so far:
- Evolve ECU tune, Alpha-N, sec. air pump delete, oct. 98, speed limiter removal
- Evolve carbon air intakes
- Evolve IATS relocate
- Evolve Medusa Headers
- Evolve 200 cell cats

And of course very happy with these mods
Marcel RSD is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW M5 Forum and M6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Adjusting viewing angle of nav screen Frits E39 M5 and E52 Z8 Discussion 32 2nd April 2018 10:15 AM
DIY: Avin Android Head Unit Install (plus new amp) Ikazuchi E39 M5 and E52 Z8 Discussion 58 25th January 2018 10:16 PM
E39 For Sale: E39 OEM 16:9 Navigation Wide Screen and MK3 (MKIII) GPS Unit Dking078 Parts / Other For Sale or Wanted 35 28th September 2017 05:36 PM
CIC Retrofit for BMW E63s - (Long and Pic Heavy) AlexMSFT E63 BMW M6 Forum and BMW M6 Convertible | m6board.com 40 20th June 2014 04:33 PM
Stereo, Sub, Woofer, DSP, Pin, Bass, Speakers V-10 4 Me E39 M5 and E52 Z8 Discussion 0 26th September 2003 07:54 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome