Help diagnosing misfires.... - BMW M5 Forum and M6 Forums
E39 M5 and E52 Z8 Discussion 1998-2003 Advertiser's Forum

 6Likes
Reply
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 14 Old 20th October 2013, 05:48 AM Thread Starter
ard
M5 Expert (>4000)
 
ard's Avatar
 
Join Date: Apr 2003
Location: Sierra foothills, CA, USA
Posts: 12,398
Thanks: 1,347
Thanked 1,754 Times in 1,125 Posts
Help diagnosing misfires....

Guys-

169k
Stock except IATS

70 miles into a 160mile drive, filled up with fuel- sketchy chevron.
45 miles later engine stumbles, 4000rpm... rough running. After 15 seconds SES light.

Next day I checked codes on the Peake:

2C Thermal Oil Level Sensor
E8 Evaporative emissions purge valve functional check’

B2 Catalyst system efficiency, Cyl #1-4"
C4 Misfire, Cyl #1"
CD Misfire during warm-up, Cyl #1
CF Misfire during warm-up, Cyl #3
D0 Misfire during warm-up, Cyl #4
D2 Misfire during warm-up, Cyl #6
D4 Misfire during warm-up, Cyl #8
D5 Misfire during warm-up, multiple cylinders
35 Electronic Fan (relay)

Cleared them...had been a year since I looked at codes...and have NOT had any SES lights... . Drove around- immediate misfiring/rough running. SES in 5 minutes

Misfire 1,6,8 and Misfire during warm up 1,6,8 plus
Misfire during warm-up, multiple cylinders. Repeatedly. No E8 returns, no ebox fan nor cat codes...I think these are noise, all I get returning are misfire codes. (although I am not driving more than 5 miles on these little trials)

(NOTE: I am pretty sure we have established the "warm up" interpretation in the Peake reader is incorrect- there are misfires and misfires with cutoff (or 'cat dmg')

Ordered plugs, fuel pump and fuel filter.... just for the heck of it, bit of a WAG, my schedule is such that I cannot screw with cars right now.

Weekend comes. Change plugs- same issue. Change fuel pump- same issue. Change fuel filter- same.

INPA on laptop to monitor stuff... nothing seems way out of whack (fuel trims, etc) except:



I can reproducibly clear errors and 1,6,8 return as misfires. if I drive it hard, I'll get the "cat damage" misfires as well.

I have NOT yet switched coils.

For reference, I also found this seemingly related thread:

https://www.m5board.com/vbulletin/e39...tenance-3.html


Remember all this started during a drive- NOT after any maintenance, etc.

Bright ideas???


Thanks!



Attached Thumbnails
IMG_1895resized.jpg  

"Keep things as simple as possible...But no simpler"

Last edited by ard; 20th October 2013 at 07:33 PM.
ard is offline  
Sponsored Links
Advertisement
 
post #2 of 14 Old 20th October 2013, 06:37 AM
Mdirty9
Addicted Member (>300 posts)
 
Mdirty9's Avatar
 
Join Date: Jul 2013
Location: Queens
Posts: 380
Thanks: 15
Thanked 19 Times in 18 Posts
Did you try switching the coils to see which coil is malfunctioning? Since you are there, I would replace the coil pack as well. It wouldn't hurt to have new ones anyway. Also I would try to get a sample of that sketchy fuel you purchased and test it or see if anybody else is having problems... If it is bad, that's a lawsuit you got...

Edit: I just realized you didn't. Switch the coils for proper diagnosis. You will know right away that which ones are bad.

2002 TIAG E39 M5 Luxury Package Extended Leather
///Dinan Muffler with Custom X-Pipe///Custom Stainles Steel Interior Trim///F10 M5 Knob///Stormworks E-Brake Handle, Nav Knobs and Illuminated Lighter Plug///Hardwired Valentine 1///Auxiliary Input///Yellow Fogs///Black Kidney Grills///Slimbones Finned Diffuser and Fog Covers///OEM Roofrack///Mdirty9 Style Headlights///ACS Roof Spoiler
///Custom Plenum and Air Boxes///

________________________________________________________________ _________________________________________________________________________

Last edited by Mdirty9; 20th October 2013 at 06:41 AM.
Mdirty9 is offline  
post #3 of 14 Old 20th October 2013, 07:05 AM Thread Starter
ard
M5 Expert (>4000)
 
ard's Avatar
 
Join Date: Apr 2003
Location: Sierra foothills, CA, USA
Posts: 12,398
Thanks: 1,347
Thanked 1,754 Times in 1,125 Posts
I'll switch coils tomorrow, but what are the odds of 3 coils going bad within the same 5 minute period after 165,000 miles?


Question: can one bad coil/cylinder have a 'dynamic' effect with the misfire sensing algorithm and cause spurious misfires elsewhere in the firing cycle? In other words are all these 'real'?

I may just move Cyl 1....where to?

A

"Keep things as simple as possible...But no simpler"
ard is offline  
 
post #4 of 14 Old 20th October 2013, 02:18 PM
gsfent
M5 Expert (>4000)
 
gsfent's Avatar
 
Join Date: Feb 2001
Location: west palm beach. fl.
Posts: 12,757
Thanks: 2,306
Thanked 1,622 Times in 1,229 Posts
Something as simple as bad gas (yes, it should show up after a mile or two of driving and one would think it would affect all cylinders)? No harm in throwing down a can of Stabil gas treatment?

Regards,
Jerry

'01 Black/caramel
Dinan Stage 3 suspension, SS jet coated headers, ESS SC kit w/ 1 range colder NGK's, 92mm pulley, 440 Big Greens, TTFS alpha N tune for meth, RK plenum plates, SBC Endurance Stage 3 Kevlar performance clutch setup, "Jed" lightened DMFW, open brake ducts, TEC cupholder, U.S.(Euro style) tilt/slide armrest, 6k HID fogs, Umnitza bi-xenon flamethrowers w/6k super white low beams, rear fogs, V1/Stealth1, dual head LI, 2.65 diff w/40% lockup/2x dynamic, compact spare, M5 logo trunk carpet, Euro trailer hitch, Mocal oil cooler, ACS type rear spoiler, Rogue custom SSK and tranny mounts, ST 355 BBK (fronts), BP sway bar brackets, Bluetooth retrofit, Speedhut boost gauge (20 psi), Dinan TB's and VS, KB BAP, Howerton/HFS-3 Aquamist WI trunk setup (50/50), with 2nd gauge in rear view mirror, aftermarket trunk mounted sound system integrated into stock unit (amps, crossovers, sub and speakers).......
gsfent is online now  
post #5 of 14 Old 20th October 2013, 02:26 PM
timmay77
M5 Expert (>4000)
 
timmay77's Avatar
 
Join Date: Feb 2008
Location: Columbus, Ohio
Age: 42
Posts: 6,939
Thanks: 1,867
Thanked 2,123 Times in 1,131 Posts
Sorry to hear of your troubles.

Check for broken/loose wires on your coil ground wires. Some of them are daisy chained. Losing a ground could cause these kind of issues.

The New Whip:
2003 Sterling Gray/Executive Caramel ///M5 (Name TBD)
~Coming soon! 5.3 LS Twin Turbo Swap. Just another LS swap, but with 2 snails.

The Storm Trooper:
2014 328i xDrive Msport Alpine White/Black Dakota (fully loaded)

~Bootmod3 stage 2~ER Downpipe~ER Charge pipe~BMS Intercooler~351M wheels

Tim ~ email: HallmanTL (at) gmail (dot) com

Last edited by timmay77; 20th October 2013 at 02:27 PM.
timmay77 is offline  
The Following User Says Thank You to timmay77 For This Useful Post:
herrubermensch (20th October 2013)
post #6 of 14 Old 20th October 2013, 02:53 PM
gsfent
M5 Expert (>4000)
 
gsfent's Avatar
 
Join Date: Feb 2001
Location: west palm beach. fl.
Posts: 12,757
Thanks: 2,306
Thanked 1,622 Times in 1,229 Posts
Quote:
Originally Posted by timmay77 View Post
Sorry to hear of your troubles.

Check for broken/loose wires on your coil ground wires. Some of them are daisy chained. Losing a ground could cause these kind of issues.

Interesting. That might explain why moving a coil wouldn't help.

Regards,
Jerry

'01 Black/caramel
Dinan Stage 3 suspension, SS jet coated headers, ESS SC kit w/ 1 range colder NGK's, 92mm pulley, 440 Big Greens, TTFS alpha N tune for meth, RK plenum plates, SBC Endurance Stage 3 Kevlar performance clutch setup, "Jed" lightened DMFW, open brake ducts, TEC cupholder, U.S.(Euro style) tilt/slide armrest, 6k HID fogs, Umnitza bi-xenon flamethrowers w/6k super white low beams, rear fogs, V1/Stealth1, dual head LI, 2.65 diff w/40% lockup/2x dynamic, compact spare, M5 logo trunk carpet, Euro trailer hitch, Mocal oil cooler, ACS type rear spoiler, Rogue custom SSK and tranny mounts, ST 355 BBK (fronts), BP sway bar brackets, Bluetooth retrofit, Speedhut boost gauge (20 psi), Dinan TB's and VS, KB BAP, Howerton/HFS-3 Aquamist WI trunk setup (50/50), with 2nd gauge in rear view mirror, aftermarket trunk mounted sound system integrated into stock unit (amps, crossovers, sub and speakers).......
gsfent is online now  
post #7 of 14 Old 20th October 2013, 03:34 PM
wuj15
Member, Sport: On DSC: Off
 
Join Date: May 2011
Location: Hong Kong
Posts: 273
Thanks: 13
Thanked 16 Times in 14 Posts
wuj15 is offline  
post #8 of 14 Old 20th October 2013, 05:10 PM
68FB
M5 Expert (>4000)
 
Join Date: Mar 2011
Location: Ontario, Canada
Posts: 4,488
Thanks: 477
Thanked 1,418 Times in 1,032 Posts
Quote:
Originally Posted by ard View Post
INPA on laptop to monitor stuff... nothing seems way out of whack (fuel trims, etc) except:



->
Are those run unrests at idle? Do they improve or get worse as you raise the rpm? Run unrests should be less than 200 with occasional spikes up to 300 at idle in my experience, like below, and improve as you raise the rpm. So you seem to have a problem to a varying degree with all the cylinders except 5. So certainly not an individual coil issue. And if it’s a common issue like low fuel pressure, why is 1 so bad and 5 OK?

Maybe time for a VANOS test just to rule that out.

Help diagnosing misfires....-inpa10.jpg

Last edited by 68FB; 20th October 2013 at 05:11 PM.
68FB is offline  
post #9 of 14 Old 20th October 2013, 08:03 PM Thread Starter
ard
M5 Expert (>4000)
 
ard's Avatar
 
Join Date: Apr 2003
Location: Sierra foothills, CA, USA
Posts: 12,398
Thanks: 1,347
Thanked 1,754 Times in 1,125 Posts
OK.. more info.

Checked Run Unrest at some rpm. Values all drop to ~100 or lower at 2500rpm. Could be just result of how this is calculated, still stumbly.

Checked all wires, ground and tohers, to coils. All good, no pinches, loose, damaged

Swapped #1 and #5 (the two FRONT-MOST coils, correct? #1 is USA passenger side front)

Here is run unrest:



Again, this evens out at 2500 rpm


After warm up I get the following 3 misfire codes:

Cyl 3
Cyl 5
Multiple Cylinders


So from a code perspective, #5 shows a fault- perhaps bad coil. Why is #3 showing an error? It was untouched. Previously it was #1 plus 6&8. Now #5 plus #3. Any thoughts?


Here is the firing order near as I can tell: 1 - 5 - 4 - 8 - 6 - 3 - 7 - 2

Im leaning toward a few coils. Replace that one that was on #1 and is now on #5..... Replace all? Buy 3,4 and see what happens?

Thoughts appreciated.

A
Attached Images
 

"Keep things as simple as possible...But no simpler"
ard is offline  
post #10 of 14 Old 20th October 2013, 08:46 PM
timmay77
M5 Expert (>4000)
 
timmay77's Avatar
 
Join Date: Feb 2008
Location: Columbus, Ohio
Age: 42
Posts: 6,939
Thanks: 1,867
Thanked 2,123 Times in 1,131 Posts
Maybe give Clemster a shout. See if he can send you some to troubleshoot with. I'm sure he has a few laying around.


Sent from AutoGuide.com App

The New Whip:
2003 Sterling Gray/Executive Caramel ///M5 (Name TBD)
~Coming soon! 5.3 LS Twin Turbo Swap. Just another LS swap, but with 2 snails.

The Storm Trooper:
2014 328i xDrive Msport Alpine White/Black Dakota (fully loaded)

~Bootmod3 stage 2~ER Downpipe~ER Charge pipe~BMS Intercooler~351M wheels

Tim ~ email: HallmanTL (at) gmail (dot) com
timmay77 is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW M5 Forum and M6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help diagnosing codes arosner92 E39 M5 and E52 Z8 Discussion 5 13th September 2012 06:36 AM
Need help diagnosing this puzzle... Brozm5 E39 M5 and E52 Z8 Discussion 7 27th December 2011 12:15 AM
Some help diagnosing Maxiiimus E39 M5 and E52 Z8 Discussion 8 25th December 2011 08:41 PM
Misfires DHUBM5 E39 M5 and E52 Z8 Discussion 18 5th August 2011 04:37 PM
Need Help Diagnosing KitchMD E39 M5 and E52 Z8 Discussion 4 5th October 2009 03:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome