Speedometer Lag - BMW M5 Forum and M6 Forums
E39 M5 and E52 Z8 Discussion 1998-2003 Advertiser's Forum

 1Likes
  • 1 Post By nosferau666
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 10 Old 10th July 2008, 04:39 AM Thread Starter
Jboud8880
Member, Sport: Off DSC: On (>50 posts)
 
Join Date: Jun 2008
Location: Warwick, RI
Posts: 92
Thanks: 5
Thanked 1 Time in 1 Post
Speedometer Lag

I pull up to a stop light just before entering the highway. I looked to my right and in the next lane was one of the road sloths (Camry). Just for fun I turned off the DSC and let it rip (sport mode always on).
The engine roared, tires spun and the camry pulled to the side of the road (must have gotten scared)...

Anyway, once tracion was established I turned onto the highway must have been pulling around 100 mph however when I looked down my speedometer was reading 45 mph.

Has anyone seen this before?
Jboud8880 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 11th July 2008, 06:56 AM
PedM5
Member, P400 Sport, DSC On (>550)
 
PedM5's Avatar
 
Join Date: Nov 2006
Location: Orange County
Posts: 576
Thanks: 33
Thanked 111 Times in 49 Posts
happened to me a couple of times, no explanation, doesn't happen every time but it's happend a few times. My gas gauge has a lag too, it won't register new gas till I turn the car on and off a few times
PedM5 is offline  
post #3 of 10 Old 14th May 2019, 06:54 PM
707M5er
Junior Member, warming up (<31 posts)
 
Join Date: May 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
bump..... had this issue too the other day on hard acceleration ... noticing tach and speedo are laggy..... defective cluster? speed sensor? ABS unit? though mine was recently replaced.... any insight would be great! btw... no check lights on of any sort
707M5er is offline  
 
post #4 of 10 Old 15th May 2019, 12:10 AM
jks540i
Member, Sport: On DSC: On (>100 posts)
 
jks540i's Avatar
 
Join Date: Oct 2007
Location: Oneonta, NY 13820
Age: 32
Posts: 134
Thanks: 2
Thanked 7 Times in 5 Posts
Not uncommon to see a latency in speedo and tach readings and the speedo usually reads 4-5 mph faster than you are going in a German car once this latency is overcome (manufacturers don't want to get blamed for speeding tickets). In your case it was probably worse due to spinning tires. Also not uncommon for sending units to stick or have bad spots in older cars. Mine doesn't register small changes, I usually brim the tank which also reduces potential for condensation inside.
jks540i is offline  
post #5 of 10 Old 15th May 2019, 02:08 AM
nosferau666
m5board.comoholic (>1000 posts)
 
nosferau666's Avatar
 
Join Date: Apr 2013
Location: Europe
Posts: 1,366
Thanks: 10
Thanked 29 Times in 20 Posts
Quote:
Originally Posted by 707M5er View Post
bump..... had this issue too the other day on hard acceleration ... noticing tach and speedo are laggy..... defective cluster? speed sensor? ABS unit? though mine was recently replaced.... any insight would be great! btw... no check lights on of any sort
I have the same issue too. Only on hard acceleration from a dig. For example I'm at 100 mph, but the speedo shows 40... it normalizes when I stop accelerating. Really makes me mad and I have no idea what could cause that.
nosferau666 is online now  
post #6 of 10 Old 15th May 2019, 10:04 PM
Redbird41
Junior Member, warming up (<31 posts)
 
Join Date: Feb 2016
Location: Phoenix
Posts: 26
Thanks: 1
Thanked 0 Times in 0 Posts
My speedo does the opposite. It will stick on a speed while the car slows down. I have to drive with a phone app to check my speed.
Redbird41 is offline  
post #7 of 10 Old 15th May 2019, 11:49 PM
Tarnjot
Junior Member, warming up (<31 posts)
 
Join Date: Feb 2019
Location: Fairfield CA
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Tarnjot is offline  
post #8 of 10 Old 16th May 2019, 01:48 PM
nosferau666
m5board.comoholic (>1000 posts)
 
nosferau666's Avatar
 
Join Date: Apr 2013
Location: Europe
Posts: 1,366
Thanks: 10
Thanked 29 Times in 20 Posts
Quote:
Originally Posted by Tarnjot View Post
it did that to me yesterday. Im thinking its got to do with the speed sensor?
I was thinking the same but I don't get any codes. Shouldn't a defective speed sensor throw a code?

Last edited by nosferau666; 16th May 2019 at 01:48 PM.
nosferau666 is online now  
post #9 of 10 Old 16th May 2019, 08:05 PM
Ferris
m5board.comoholic (>1000 posts)
 
Join Date: Dec 2012
Location: New Jersey
Posts: 1,319
Thanks: 4
Thanked 129 Times in 118 Posts
Has anyone checked what Inpa reported, I think the cluster and DME both output it.

2001 E36/7 MRoadster
2001 E39 M5
2010 E60 M5
2008 E90 335xi
Ferris is offline  
post #10 of 10 Old 16th May 2019, 08:31 PM
Tarnjot
Junior Member, warming up (<31 posts)
 
Join Date: Feb 2019
Location: Fairfield CA
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Hmm, good point. This only happens on M5's? I wonder if anyone with a 540 has it. If so does it only happen on ones with LSD?
Tarnjot is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW M5 Forum and M6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Calculating Speedometer Error? MRichmond E60 M5 and E61 M5 Touring Discussion 3 10th July 2007 12:56 PM
Test drove the 335i bi-turbo today max berger E90 M3 Sedan, E92 M3 Coupe, E93 M3 Convertible, E46 M3 and E36 M3, Z4 M and Z4 M Coupe 75 21st December 2006 12:43 PM
Speedometer Accuracy cam5wannabe E60 M5 and E61 M5 Touring Discussion 46 11th June 2006 11:29 PM
speedometer reading l8apex32 E39 M5 and E52 Z8 Discussion 1 18th November 2003 01:32 AM
Need a speedometer.....quick Steven E34 M5 Discussion 1 3rd January 2003 08:23 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome