M5 vanos or cps? - BMW M5 Forum and M6 Forums
E39 5 series Forum Dedicated to the E39 5 series.

 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 1 Old 23rd June 2019, 04:30 PM Thread Starter
Sondre Larsen
Junior Member, warming up (<31 posts)
 
Join Date: Jun 2019
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
M5 vanos or cps?

Hello, i just cleaned out my vanos solinoids, because i had fault codes. I replaced the o rings and tested them, the fault codes lead to bank 2. When i had replaced them and started it, i got the same codes as when i started. 4B Activation, inlet VANOS, bank 2, raterd valve and 71 Fucntion, inlet VNAOS, bank 2. I took the solinoid board out again, and tested them again. All of them worked, put it back in the car. And then i got two more fault codes. 53 Activation, exhaust VANOS, bank 2, advance valve and 72 Function, exhaust VANOS, bank 2. This time the car started to miss fire and stall. Could it be a camshaft sensor that triggers these faults? Since i have cleaned and tested the solinoids and no codes cleared?
Sondre Larsen is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW M5 Forum and M6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome