I-Drive screen gone - BMW M5 Forum and M6 Forums
Australian Forum For Australian owners and enthusiasts of m5board.com and gtboard.com

 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 2 Old 19th September 2011, 06:28 AM Thread Starter
Gunsbuns
Junior Member, warming up (<31 posts)
 
Join Date: Jul 2011
Location: Sydney Australia
Posts: 20
Thanks: 5
Thanked 4 Times in 3 Posts
I-Drive screen gone

Has anyone had their I-Drive screen go blank with associated loss of functions (Nav, stereo, etc). I've done a bit of researching and it looks like the CCC may be on the way out. After a night it resets itself but goes out again after 10 - 20 minutes driving. I've treid the reset thing (pressing the DVD, CD and mute button together) but this only sometimes works. I get either one or sometimes two error codes - the yellow car on the hoist and the SOS and phone icon crossed out.
Any thoughts?
Gunsbuns is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 1st October 2011, 02:53 AM
NBTBRV8
Member
 
Join Date: May 2010
Location: Australia
Posts: 48
Thanks: 1
Thanked 3 Times in 3 Posts
Looks like your going to have to get it scanned to identify th fault. It might pay considering the cost difference between replacing the CCC and moving to a CIC.
NBTBRV8 is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW M5 Forum and M6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
I drive screen went blank? dimitri E60 M5 and E61 M5 Touring Discussion 7 18th September 2008 02:28 AM
M5 Logo on i drive screen ? bavaria1 E39 M5 and E52 Z8 Discussion 1 4th July 2006 02:52 AM
I liek the split screen on i-Drive BostonRocket E60 M5 and E61 M5 Touring Discussion 3 15th November 2005 10:16 PM
Headrest Monitors & I-drive screen mcw331 E60 M5 and E61 M5 Touring Discussion 4 8th November 2005 09:15 PM
I-drive start up screen - Australian cars mhh E60 M5 and E61 M5 Touring Discussion 14 3rd October 2005 11:12 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome