Indicator stalk not working - BMW M5 Forum and M6 Forums
Australian Forum For Australian owners and enthusiasts of m5board.com and gtboard.com

 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 2 Old 2nd July 2010, 04:57 AM Thread Starter
Brisbane M5
Addicted Member (>300 posts)
 
Join Date: Jun 2010
Location: Brisbane, Australia
Posts: 350
Thanks: 37
Thanked 20 Times in 20 Posts
Indicator stalk not working

Guys,

Picked my M5 up last week and had the indignity of having to take it back to Motorline BMW in Brisbane yesterday to get the indicator stalk fixed.

The problem actually started the day I picked the car up - of course I didn't want to take it back to the dealer immediately and therefore waited until yesterday.

SYMPTOMS - what was it doing?

1. every time the headlights were turned on the highbeam remained on. This is not such a problem because I have the active high beam (or whatever it is called - it self dips) - but that's not the point. It should work. Also the flash would never work.
2. the indicators only worked every couple of times i started the car.
3. the OBC would not scroll through the various "screens"/functions.

DIAGNOSIS

Faulty stalk

FIX

Replace stalk by overnighting the part from Sydney

COST

Free - ain't warranties grand?!
When I pick the car up I will however enquire what the cost would have been and let you all know.

Cheers.

Tim.
Brisbane M5 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 12th July 2010, 12:15 AM
M5aud
Member, P500 Sport, DSC off (>900)
 
M5aud's Avatar
 
Join Date: Feb 2010
Location: Australia
Posts: 977
Thanks: 33
Thanked 66 Times in 57 Posts
M5aud is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW M5 Forum and M6 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
OBC/high beam stalk malfunction Brisbane M5 E60 M5 and E61 M5 Touring Discussion 3 27th June 2010 09:40 AM
Indicator canamracer E39 M5 and E52 Z8 Discussion 0 21st September 2009 12:43 AM
What is this indicator? Somebody knows? GreenEyes E39 M5 and E52 Z8 Discussion 11 5th September 2009 09:24 AM
Oil level indicator not working... liquido E60 M5 and E61 M5 Touring Discussion 16 20th September 2006 07:58 PM
Danger! Danger! Will, Penny, E60 Has Retarded Turn-signal Stalk And I-drive!!! zzzzMD E60 M5 and E61 M5 Touring Discussion 14 8th July 2003 12:33 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome