BMW M5 Forum and M6 Forums banner

7941 - 7951 of 7951 Posts

·
Registered
Joined
·
218 Posts
Word of warning on the STR-60- documentation with them says to torque the nuts on the front bracket to 43 ft/lbs, don’t do that- it’s actually 32, and Dave Zeckhausen recommends 24. 43 ft lbs will pull the studs out of the brackets (ask me how I know...). Luckily they admitted fault and sent me a new pair of them, even though only one pulled.
Matt, huge insights. Glad yours worked out. Really appreciate the heads up.
 

·
Registered
Joined
·
184 Posts
Changed the leaky lower oil pan gasket and oil sensor. While thankfully there was no plastic in the pan. I can't help but wonder about this with the pan. Is this a concern or am I being paranoid? No weird noises other than the vanos rattle.
Screenshot_20200701-173935_Gallery.jpg


Sent from my SM-G975U using Tapatalk
 

Attachments

·
Registered
Joined
·
229 Posts
wow, that all looks super clean and nice

the casting imperfections, does look a little messier than others online, dont see how it can affect anything
 

·
Registered
Joined
·
184 Posts
Was wondering because it's right under where the pump would be. Checked to make sure the bolts for the pump were nice and snug. They were so I guess it's nothing to worry about.

While the inside of the pan was nice and clean. The outside was another story. Scrubbed it with a stiff nylon brush with brake parts cleaner to clean up all the years of caked on gunk. Wish I could give the rest of the underside of the car the same treatment lol.

Sent from my SM-G975U using Tapatalk
 

·
Registered
Joined
·
167 Posts
Opened the box containing the uprated engine mounts from e39 engineering.. hope to get them fitted next week.



Sadly I think these are some of the last ones...


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
184 Posts
Phew all done. Spent the weekend replacing the valve cover gaskets on the beast along with a couple other things underneath such as the hose that connects the idle control valve to the throttle bodies and the other that connects the ICV to the plenum. Spritzed some carb cleaner in the ICV with the car running, runs nice and smooth.

Then today I got around to replacing the infamous power steering hoses and reservoir along with some fresh Mobil 1 ATF. Still a teeny bit of noise so probably going to bleed it some more in a bit. Bolted the belly pan back up and tomorrow I'm going to take it on a nice long drive again to see how everything holds up.

Annoying part was while replacing the other half of the vacuum hose that connects at the brake booster, I wanted to replace the grommet it for it as well, and low and behold, I dropped the damn new one and it landed in a spot below the booster that I can't get to at all. So had to use the old one again. Oh well, at least it was still in good shape.

Now if you'll excuse me I have to go shower. I reek of a combination of body odor and power steering fluid with a hint of brake parts cleaner and motor oil lol.


No surprise it was nice and clean underneath the valve covers. Not a single trace of sludge.
20200704_182330.jpg
20200704_155026.jpg


Sent from my SM-G975U using Tapatalk
 

·
Registered
Joined
·
167 Posts
Changed the oil, something I do annually or every 5k miles. I only covered 2.9k last year.





And yes I do love the vacuum pump. It takes a while but after checking it the first time it gets as much out as using the drain plug.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
195 Posts
I use the pump as well. Eliminates the need to crawl under the car, something I have come to dislike as I get older. Sadly, it doesn't work on newer BMWs as they eliminated the dipstick.🙁
 
7941 - 7951 of 7951 Posts
Top