BMW M5 Forum and M6 Forums banner

21 - 34 of 34 Posts

·
Registered
Joined
·
719 Posts
My understanding is that you should put 100km on the new o-rings before doing the test again.


So here my update guys..... installed the “repaired solenoids with new o-rings” that was provided to me by @Redleg9 and here were my results....

Car idled smooth unlike before it idled as if it had a CAM in it like a Vette. HERE my issue though I still have vano faults and car won’t idle long enough before it actually SHUTS OFF. Not sure why this is happening. My next step is to checking engine “timing” with the s85 timing tool, and if that is good then it has to be my vano units that are bad. Soooo I’m still without my car.

Good news solenoids read consistent across the board and repair seems to work that Troy did for me, but news still has vano codes and car won’t stay on longer than 2min before it drops idle and shuts off with vano codes...

Any suggestions or help would be appreciated.







Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
719 Posts
It does, I don’t think I took a pic... but it was Fault codes for both banks. Intake and exhaust something for vanos. I will try and get pic


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
121 Posts
So here my update guys..... installed the “repaired solenoids with new o-rings” that was provided to me by @Redleg9 and here were my results....

Car idled smooth unlike before it idled as if it had a CAM in it like a Vette. HERE my issue though I still have vano faults and car won’t idle long enough before it actually SHUTS OFF. Not sure why this is happening. My next step is to checking engine “timing” with the s85 timing tool, and if that is good then it has to be my vano units that are bad. Soooo I’m still without my car.

Good news solenoids read consistent across the board and repair seems to work that Troy did for me, but news still has vano codes and car won’t stay on longer than 2min before it drops idle and shuts off with vano codes...

Any suggestions or help would be appreciated.







Sent from my iPhone using Tapatalk

Can you elaborate on " repaired solenoids"
What exactly did Troy do to them?


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
719 Posts
My understanding is that you should put 100km on the new o-rings before doing the test again.


To be honest I really don’t know what all were entailed as to what he did but it certainly worked and got my values up to OK status along with o-rings


Sent from my iPhone using Tapatalk
 

·
Moderator
Joined
·
2,179 Posts
Hmm... are you actually running the solenoid test or simply reading the stored values? The fact that all 4 read exactly the same is unusual. Simply resetting vanos adaptations sets all 4 back to 0.85. Sounds like you're simply seeing the stored values after adaptations were reset.
 

·
Registered
Joined
·
719 Posts
Hmm... are you actually running the solenoid test or simply reading the stored values? The fact that all 4 read exactly the same is unusual. Simply resetting vanos adaptations sets all 4 back to 0.85. Sounds like you're simply seeing the stored values after adaptations were reset.


Yea I actually ran the test and remember these were repaired. I believe I shared my before and after results.... it wasn’t a rest though, we definitely ran the solenoids test plan


Before


After



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
93 Posts
Discussion Starter #30
So here my update guys..... installed the “repaired solenoids with new o-rings” that was provided to me by @Redleg9 and here were my results....


Sent from my iPhone using Tapatalk
For clarity's sake, I provided the O-rings, not the solenoids. I had a few extra Viton o-rings and squared M V10 Power away with a set.
 

·
Registered
Joined
·
719 Posts
For clarity's sake, I provided the O-rings, not the solenoids. I had a few extra Viton o-rings and squared M V10 Power away with a set.


That is correct. Thank you for that and it def seemed to help and make a difference in addition to me having Troy repair my solenoids. Thanks again


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
255 Posts
Ordered Viton o-ring set!


Sent from my iPhone using Tapatalk
 
21 - 34 of 34 Posts
Top