BMW M5 Forum and M6 Forums banner
1 - 20 of 20 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I got the Transmission Malfunction warning today on my 2008 M5 and car feels almost like a slipping clutch. Car is 7spd SMG and I had the European trans software w/ Euro lauch installed. Think I'll have a problem at the dealer with the changed software? Thanks for any tips
 

·
Registered
Joined
·
407 Posts
As I always recommend, have you tried the SMG reset during drive? It seems to work wonders. This resets your clutch position sensor. Attempt this before you give into the dealer. :M5thumbs:
 

·
Registered
Joined
·
407 Posts
I have not heard of that, thank you. Is it through Idrive? Thanks again
Follow this procedure: While driving anywhere between 20 and 90mph, put the car into neutral and then simultaneously hold both paddles back for ~3-5 seconds. This will reset your clutch position sensor, and your shifting will become smoother. A lot of people do it as routine maintenance every 2K miles or so, and after getting new wheels and tires and stuff.

Try it, and let's see if there's any progress! GL! :M5thumbs:

Oh ok, I was a bit late. GL :p
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #9 ·
Thanks but unfortunately it didnt work. It's not looking too good. If you get on the gas even a little it revs a lot before engaging and then I get the message again. Let you know what happens. Thanks for the help
 

·
Registered
Joined
·
93 Posts
Thanks but unfortunately it didnt work. It's not looking too good. If you get on the gas even a little it revs a lot before engaging and then I get the message again. Let you know what happens. Thanks for the help
i think the last person i heard say this just needed a new clutch and flywheel...i am guessing u have launched the car with the euro LC lol about 6 times of the will do it
 

·
Registered
Joined
·
118 Posts
I got it from the Westside BMW here in Houston a few months ago. Took the car in after a coolant leak, reduced power, and suspected coolant in the oil. Turned out to be a loose hose clamp causing the coolant leak and a VANOS HP supply line for the reduced power. Dealership covered 2/3 of the VANOS parts and labor under the goodwill deal. According to them, BMW corporate covered 1/3, the local delaership covered 1/3, and I covered the last third. It's not something they have to do, and now that I know about it I will make sure I ask about it in the future if something like this comes up. Have to give kudos to the dealership for this. Not something they have to do and they saved me about $1,400.

Mickey
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #20 ·
Is your 05 out of warranty yet? For me it was BMW Corporate that covered it but they had the car for a week. They said that since it didnt appear that I had any mod's then they would cover it. Good luck
 
1 - 20 of 20 Posts
Top