BMW M5 Forum and M6 Forums banner

1 - 20 of 28 Posts

·
Registered
Joined
·
291 Posts
Discussion Starter · #1 ·
I got the transmission malfunction alert again 2 nights ago. But this time it was the yellow one.
The first time I got it was in April, the red message which left me stranded in the Bronx. Lol
It took about 2 weeks to get it back from the dealer. I wasn't charged anything since I still got the warranty. Back then it was stock but this time I just have the rpi pulley and AA exhaust.
You guys think they'll give me any problems with the warranty cause of these things?
If so, so I can take them off.
 

·
Moderator
Joined
·
8,369 Posts
It is common for dealers to find a reason not to honor warranty.

If I were you - I would remove any aftermarket mods prior to taking your beast to the $tealer.

Can you share what transmission malfunction messages you get?

I got the transmission malfunction alert again 2 nights ago. But this time it was the yellow one.
The first time I got it was in April, the red message which left me stranded in the Bronx. Lol
It took about 2 weeks to get it back from the dealer. I wasn't charged anything since I still got the warranty. Back then it was stock but this time I just have the rpi pulley and AA exhaust.
You guys think they'll give me any problems with the warranty cause of these things?
If so, so I can take them off.
 

·
In Memoriam
Joined
·
2,398 Posts
Not a real problem if the alert signal is for a few seconds. Common M6 electronic glitch. Restart the car and it will be fine.

On the other hand if it stays on, it may be software related or the hydraulic SMG pump.
 

·
Registered
Joined
·
291 Posts
Discussion Starter · #4 ·
It is common for dealers to find a reason not to honor warranty.

If I were you - I would remove any aftermarket mods prior to taking your beast to the $tealer.

Can you share what transmission malfunction messages you get?

yea, i already called the place where i got my exhaust put on and on monday im going to get the whole thing removed.
cause my dumbass didnt research so well and i didnt know the AA exhaust was for all 3 sections of the exhaust lol
and here is a picture of the transmission malfunction message. this is the yellow message which my car didnt turn off this time. last time i got it, the little gear was red.

photo.JPG
 
  • Like
Reactions: whatheheck

·
Registered
Joined
·
291 Posts
Discussion Starter · #5 ·
Not a real problem if the alert signal is for a few seconds. Common M6 electronic glitch. Restart the car and it will be fine.

On the other hand if it stays on, it may be software related or the hydraulic SMG pump.
nop didnt work. i used my car today again and i try reving over 4 rpm and it lags. after that if i force it more. that message comes up.
so ill have to take it to the dealer after i remove the mods i have on it.
 

·
Registered
Joined
·
291 Posts
Discussion Starter · #6 ·
It is common for dealers to find a reason not to honor warranty.

If I were you - I would remove any aftermarket mods prior to taking your beast to the $tealer.

Can you share what transmission malfunction messages you get?
lmao... the "$tealer"
i like that name for them. :grinyes:
 

·
Moderator
Joined
·
8,369 Posts
When you get a fault message like that - no other choice but to take it to the $tealer.

You are lucky that your beast is still under warranty. As we all know, BMW's especially their M cars are expensive to acquire and maintain.

Keep us posted.

THanks.

yea, i already called the place where i got my exhaust put on and on monday im going to get the whole thing removed.
cause my dumbass didnt research so well and i didnt know the AA exhaust was for all 3 sections of the exhaust lol
and here is a picture of the transmission malfunction message. this is the yellow message which my car didnt turn off this time. last time i got it, the little gear was red.

View attachment 123438
 

·
Registered
Joined
·
579 Posts
Sorry to hear of your problems M6_AGU. Not sure but the dealer shouldn't have a problem with the exhaust as far as honoring the warranty. My dealer told me exhaust & intake mods are fine and won't alter the warranty. The pulley may be an issue if they notice it though. Not to make you feel worse but I've seen enough problems here on the boards with the SMG which makes me more happy that I chose the MT.
Good luck & Merry Christmas!
 

·
Registered
Joined
·
66 Posts
first smg issue...

Ok guys.. after having a nice xmas w the family.. while on my way home my car started to stall and felt Like I got a tap from behind... then it died on me... waited 30 min n was able to get it moved to a safe place but feels like its going to stall (jerky feeling) and smelled some smoke..... now can I drive for 30 miles to get it home?
 

·
Registered
Joined
·
64 Posts
When you get a fault message like that - no other choice but to take it to the $tealer.

You are lucky that your beast is still under warranty. As we all know, BMW's especially their M cars are expensive to acquire and maintain.

Keep us posted.

THanks.
Totally agree with Whatheheck, when you have a fault message, dont wait, take it to the specialist. I had the same message with yellow, but after i restarted the car, it went away. It happened a few times, and every time i restarted, it went away. I kept doing it until it wore my clutch down, so i made it more expensive...
 

·
Registered
Joined
·
291 Posts
Discussion Starter · #12 ·
Alright guys. I finally got my car back on Monday. Everything is good now.
The S/A said it was the clutch. He called me Saturday morning telling me that the reason why I got the message was because the clutch was messed up. He said that he had to measure the clutch and make sure it was covered under the warranty. That if it fell under 1mm I wasn't going to be charged anything, but if it was more than 1mm I was going to be charged for a new clutch which was $3,000.00. Lucky me, i saw the reciept and on the last page it said that the clutch was worn down to 0.79mm.
On Monday I wanted to ask him in person if he can explain to me in detail why it might've have happened. But he had left home by then.
Do any of you know why it might've have happened.
 
  • Like
Reactions: whatheheck

·
Registered
Joined
·
198 Posts
I got a red cog for a moment last week after starting the car (warm start), went away on a restart

Went to the dealer today to get it checked cause I wanted it on record as looked at incase they tried to use an old code as a reason for a future failure(knock on wood). Ended up being a SMG low pressure fault, but hasn't come back up since and all their tests (supposedly 7 of them) came back green. I'd recommend getting it at least diagnosed.
 

·
Registered
Joined
·
1,121 Posts
just got this warning message yesterday. My car works just fine, the warning sign going on and off on my beast. My car is currently 54k miles and out of warranty. I got a bad feeling that I have to get a new clutch!grrrrrrr
 

·
Registered
Joined
·
291 Posts
Discussion Starter · #17 ·
just got this warning message yesterday. My car works just fine, the warning sign going on and off on my beast. My car is currently 54k miles and out of warranty. I got a bad feeling that I have to get a new clutch!grrrrrrr
Be careful because the beast might leave you stranded like it did to me. :sad1:

and since its out of warranty then I your gonna have to pay that 3K for a new clutch. Im crossing my fingers for you man. I wouldn't want anybody else to go through this but unfortunately it happens often.
 

·
Registered
Joined
·
291 Posts
Discussion Starter · #18 ·
and im also wondering why they said you had to pay if it was more then 1 if your still under warranty?
Thanks man. But I've been to 2 different dealerships and so far they haven't said anything about the aftermarket exhaust. I thought they would but no, they never blamed the exhaust for anything.
Yea i was confused too about why I'd get charged if i was still under warranty. but I stopped going to that dealership since they lied to me saying I couldn't get extended warranty because i was just 7 miles over my 50,000 miles.
 

·
Registered
Joined
·
1,121 Posts
Be careful because the beast might leave you stranded like it did to me. :sad1:

and since its out of warranty then I your gonna have to pay that 3K for a new clutch. Im crossing my fingers for you man. I wouldn't want anybody else to go through this but unfortunately it happens often.
Thanks buddy! I know this thing is going to hit me sooner or later since my beast is currently rolling for 54k miles. I am really thinking to sell the beast instead, because of the ridiculous error that popped up. The beast is a lot of fun but not as reliable as I thought.
 

·
Registered
Joined
·
291 Posts
Discussion Starter · #20 ·
Thanks buddy! I know this thing is going to hit me sooner or later since my beast is currently rolling for 54k miles. I am really thinking to sell the beast instead, because of the ridiculous error that popped up. The beast is a lot of fun but not as reliable as I thought.
yea it really is a whole bunch of fun but not so much as reliable as it looks. Yea, I'm going to sell mine too, in maybe a year. So far I've had 3 Red Cogs since I've purchased it. One more red cog and its bye bye M6.
Good luck though, and like i said, be careful because it sucks when the beast leaves you stranded on the road. Get it checked out by a shop near by maybe they can give you an idea of whats really wrong with it.
 
1 - 20 of 28 Posts
Top