BMW M5 Forum and M6 Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
189 Posts
Discussion Starter · #1 ·
Driving normally in the car with the wife last night, level ground 1/4 tank third or fourth gear around 3000 turns and all of a sudden the SES light pops on to say hello. Nothing unusual for a couple of seconds, then the car begins to shake, and bad. Shakes bad while applying throttle between 2000 - 3000 rpm's. Don't really know if it would shake anywhere else in the rev band, that's where I kept it. I didn't have a chance to pull over because I was coming up on the ravenel bridge and in traffic. As soon as it appeared, it was gone and so was the vibration. Probably lasted about 60 seconds at the most.

Took it into my indy today and had my computer read for yesterday's codes.....

CD Misfire Cylinder 1, without cylinder cut-out
D6 Misfire Cylinder 4, without cylinder cut-out
D3 Misfire Cylinder 7, without cylinder cut-out
D4 Misfire Cylinder 8, without cylinder cut-out
D5 Misfire, several cylinders, with cylinder cut-out
CB Misfire Cylinder 8, with cylinder cut-out
C5 Misfire Cylinder 2, with cylinder cut-out

I did use search and it sounds like the warning signs of fuel pump failure or some other fuel related problem. I do use this car as my DD, and I'd like this resolved asap. The indy said possibly a fuel pump solenoid maybe the culprit, but he wasn't 100%. His shop was full and he only took me in last minute just to read my codes for me. The fuel filter was done about 10K miles ago but the pump is original (car has 49,500 miles) Also, do you think I harmed the car as I drove through the fault? The car feels fine today, feels like it has full power (didn't redline it, but it pulls as strong as ever).

- matt
 

·
Registered
Joined
·
189 Posts
Discussion Starter · #8 ·
recent tune?

Are you absolutely sure you didnt ALSO get one of these four codes : B8, B9, 71 or 72.

I suspect Vanos Solenoid Failure. (shaking in a certain rev range.....an abundance of misfire codes on all cylinders....)

Good Luck

Ya I'm sure, those 7 codes are exactly what was seen off my indy's diagnostics cart, no other codes.

Another area I'd like to rule out is my recent powerchip's 93 octane tune. I wonder if a tank of gas of inferior quality could do that to the engine now that it's more sensitive to fuel quality? I don't put anything less than 93 in and from major fuel company's. Also, I don't want to point fingers, those powerchips guys are great and I do love my new tune, but I'm just wondering? I should give powerchip's a call and see if this is even in the realm of possibility, or maybe they can chime in here.
 

·
Registered
Joined
·
189 Posts
Discussion Starter · #9 ·
Test 6. 1st part shows L/R and Total in pretty much real time from the sensors. 2nd part shows the damped total.

Gotta love that secret menu, I'll be doing this on my ride home from work today to verify volume
 

·
Registered
Joined
·
189 Posts
Discussion Starter · #10 ·
Could be the Left Sucking Jet Pump which moves (siphons) fuel from the left side of the tank to the right side where the pump is located. If this malfunctions you will have fuel in the left side and the gauge will register as such, but you can't get to it! #7 in this diagram. It's obvious whne you open the tank covers...all the fule is in the left side.

See #7 in this diagram:
RealOEM.com BMW E39 M5 Fuel pump and fuel level sensor


I believe you nailed it.

I've been driving around for the last couple months using the secret menu fuel table, the shaking and vibration still has yet to return but there is always fuel in the left side of the tank when I go to fill up (according to the display). The left side should always suck done completely first, correct? A few weekends ago at Autozone I met a board member and he was surprised this fuel issue has only happened to me once. Guess this is a common issue?
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top