BMW M5 Forum and M6 Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
224 Posts
Discussion Starter #1
Hello, I just got a 2006 M5 earlier this week, 87k miles, everything inside works perfectly except for the steering column adjustment and it's stuck fully up.

I took the under dashboard cover off and did some diagnosing. INPA shows that the little switch in the column is working, i see signals for all 4 directions. When I check the wiring at the motor though I'm not getting any volts at all.

I checked the fuses i could think of, 71 in trunk and 2 other fuses which power the central body module just in case. they're all fine.

I can't find any information on this issue anywhere and any help is greatly appreciated.

Can anyone point me to ecu controls the steering column in inpa?


Thanks
maddios is online now Report Post
 

·
Registered
Joined
·
13,456 Posts
Have you tried to lock the car and leave it for 5 mins then unlock the car and see if the steering wheels frees up when starting the car?
 

·
Registered
Joined
·
224 Posts
Discussion Starter #3
yeah, it's been like this since I picked it up on wednesday.

I don't hear anything ticking or moving at all. I already disassembled the dashboard under the steering column and checked for voltages at the motor and there's nothing, 0.0v there.

So either my central body module is toast or something else. Any pointers on where to look would be greatly apreciated.

Can anyone point me to the specific module in INPA which is responsible for controlling the steering wheel (actual driver)?
 

·
Registered
Joined
·
224 Posts
Discussion Starter #5
thanks for the info, I checked the SZM module and there were no faults stored.

At this point i'm wondering if it's a wiring problem or the module is just toast, like a relay/transistor ate it and the module doesn't know about it.


where is the SZM located so I can take a look at it?


PS: I'm trying to use the WDS but this thing is so hard to read compared to the old school wiring diagrams from cars like the e34/e24 that i'm used to.
 

·
Registered
Joined
·
1,131 Posts
I had this problem after the SZL was replaced, the whole car has to be programmed after changing the SZL. The steering column motor did not work after programming, it had to be programmed again and then the motor on the steering column worked.
 

·
Registered
Joined
·
224 Posts
Discussion Starter #7
So, I think my central console center switch unit is dead. I pulled it out, it's getting power but not activating the steering wheel.

No errors stored in it and the actual steering column buttons are working when I diagnose them in inpa.

If I get another control unit and swap it in, I don't have to code it, right? as long as it has the same functions it should work.
 

·
Registered
Joined
·
224 Posts
Discussion Starter #8 (Edited)
I had this problem after the SZL was replaced, the whole car has to be programmed after changing the SZL. The steering column motor did not work after programming, it had to be programmed again and then the motor on the steering column worked.
Ah, hm, maybe i should check to make sure it's not a programming issue. Though I doubt mine was ever replaced.
 

·
Registered
Joined
·
224 Posts
Discussion Starter #9
I googled around but I'm not sure what I'm looking for, anyone have a guide for "programming" the module to make sure it knows it's supposed to control a steering wheel?
 

·
Registered
Joined
·
224 Posts
Discussion Starter #10
So I got a replacement center console button unit. It's exactly the same as mine, still no dice.

So either this one has the same exact problem (got it used) or it is indeed a coding issue.

I'm going to look at the coding this weekend maybe and try to figure out what's the deal. Any coding advice is welcome as I've never tried to do this before, I've just messed with stuff like rolling up windows with remote.

I'm going to do a bunch of research on the bmwcoding forum right now.
 

·
Registered
Joined
·
224 Posts
Discussion Starter #11
So, PRM5 was right on, in my case it was a programming issue. I recoded the SZL with defaults and my steering wheel works now :biggrinbounce:

Really wonder what the hell previous owner or their shop did to screw this up.
 

·
Registered
Joined
·
1,131 Posts
So, PRM5 was right on, in my case it was a programming issue. I recoded the SZL with defaults and my steering wheel works now :biggrinbounce:

Really wonder what the hell previous owner or their shop did to screw this up.
Glad you got it figured out :cheers:
 

·
Registered
Joined
·
224 Posts
Discussion Starter #13
that being said, I now have a spare SZM :) anyone need one?

It's the one with heated seat, pdc and tpm buttons.
 
1 - 13 of 13 Posts
Top