BMW M5 Forum and M6 Forums banner

21 - 29 of 29 Posts

·
Registered
Joined
·
1,105 Posts
Still no idea off what is the problem, the shop take the engine out off the car. Removed the oil pan and what do you think everything looks fine. So no spun bearing, now they are gonna lift the valve covers and inspect the heads.
Sorry, I doubt they know what they are doing. Its a bad situation.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #22
Today I went to the shop and they found the problem one off the valve conducturs was bend. So the cilinderhead need a revision so we Will see...
 

·
Registered
Joined
·
33 Posts
Discussion Starter #24
2 valve needs to be replaced, Some conductors need to be replaced. No further damage to the engine thank god. No pics they al ready send the cylinderhead to another shop for repair. I Love this car but all the problems are killing me slowly.
 

·
Moderator
Joined
·
1,737 Posts
Those valves hit a piston and the piston and conrod are fine? Not impossible but unlikely...

What do you mean by 'conductors'?
 

·
Registered
Joined
·
33 Posts
Discussion Starter #26
No the valves did not hit the piston, I have seen the engine myself. Piston and cylinderwall looking fine to me. I dont now How you name Some Parts in English. A part dat conducts te valve failed. The only problem that I had with the car whas a loud ticking/knocking sound from the engine. no rough idle, no codes or other warnings from te car.
 

·
Registered
Joined
·
31 Posts

·
Registered
Joined
·
1 Posts
Still no idea off what is the problem, the shop take the engine out off the car. Removed the oil pan and what do you think everything looks fine. So no spun bearing, now they are gonna lift the valve covers and inspect the heads.
Hi I am not an expert but had similar noise from my 523I 2.5 petrol ,
I did a lot investigation on it vanos valve tronic Hydraulic lifters timing chain , was non of the above ,
Remove your serpin tine belt and see if it goes away My sure did ,
Turned out to be the AC compressor had failed replaced timing chain while had cams out only 100 k on my car but did chain while was there and replaced the AC compressor .
asked on a lot of fourms and got all the usual answers
but was my AC compressor
 
21 - 29 of 29 Posts
Top