BMW M5 Forum and M6 Forums banner

21 - 33 of 33 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #23
Do you have the name of the vendor where you sourced the front bumper? How was the fitment?
Im not sure who makes this bumper but I got it off eBay. In the next video I’ll try to see if I can find any stamps or stickers of the brand or who made it possibly.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #24
She’s coming along pretty nicely, however I do need both of the maf housings. Anyone here has them laying around? Don’t think I need the sensor just the housing. Let me know!
 

·
Registered
Joined
·
15 Posts
Discussion Starter #25
There was no indication of the brand or supplier of the front bumper. I will post a link in the video description where I got it if anyone is interested. Other then that the car made it home safely without the need of a tow truck although I noticed the needle on the coolant temp gauge seems a bit low. If anyone wants to chime in as you can see it in the video when I’m driving back home. Super happy with the car as it sits and can’t wait to take her on a road trip!

 

·
Registered
Joined
·
168 Posts
There was no indication of the brand or supplier of the front bumper. I will post a link in the video description where I got it if anyone is interested. Other then that the car made it home safely without the need of a tow truck although I noticed the needle on the coolant temp gauge seems a bit low. If anyone wants to chime in as you can see it in the video when I’m driving back home. Super happy with the car as it sits and can’t wait to take her on a road trip!

When my cars temp gauge didn’t rise to optimum it was due to a bad thermostat. Even after a 30 min drive the temp gauge would only rise to about 1/3 if that. However in the vid your coolant and oil temp gauges look normal. The oil and temp gauges don’t sit at 12’O clock when cruising, they sit more around 10/11’O clock. Apparently the thermostat gets stuck open when they fail in our cars causing to it over cool. And It’s not good to drive it w a failed t stat. It would be running rich all the time, and bad mpg. I got my Tstat fixed when I first got my car and I noticed better efficiency immediately. Who ever does the job make sure you order the temp sensor and some extra sets of those ring seals for the T stat housing. I think it was 3 seals total. The seals can break easily when you reinstall the Tstat housing and you’ll be pissing coolant all over the place. Ask me how I know.

That engine sounds great. And I’m really liking that piano black interior trim. I remember seeing this car totaled from your first vid. Props to you for bringing it back to life man it really looks and sounds great. That LMB gets me every time.
 

·
Registered
Joined
·
17 Posts
She’s coming along pretty nicely, however I do need both of the maf housings. Anyone here has them laying around? Don’t think I need the sensor just the housing. Let me know!
I just replaced my MAFs yesterday. I have my old ones if you need them. PM me if you’re interested.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
63 Posts
Nice video. I'm pretty sure that 'ticking' sound is the infamous S62 diesel rattle - basically the sound of the Vanos gears. From what I've read this is a non-issue, only fix if the sound bothers you.

Only thing that's missing is the link to the front bumper! There are so many bumpers on eBay. I am sure they are all the same but would like to purchase one from the same seller as you just to make sure the fitment is fine.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #30
Nice video. I'm pretty sure that 'ticking' sound is the infamous S62 diesel rattle - basically the sound of the Vanos gears. From what I've read this is a non-issue, only fix if the sound bothers you.

Only thing that's missing is the link to the front bumper! There are so many bumpers on eBay. I am sure they are all the same but would like to purchase one from the same seller as you just to make sure the fitment is fine.
Yeah I was thinking the same thing and wasn't too worried. Gonna do a fresh oil change as soon as I start driving it and Ill see if it gets any quieter after couple hundred miles or so.
Sorry, couldn't get the link of the front bumper posted as the seller is not selling that bumper any more. I don't know if its temporary or if I bought the last one he had. You can maybe check up or ask him on ebay. Seller name is speed_daddy
 

·
Registered
Joined
·
15 Posts
Discussion Starter #31
When my cars temp gauge didn’t rise to optimum it was due to a bad thermostat. Even after a 30 min drive the temp gauge would only rise to about 1/3 if that. However in the vid your coolant and oil temp gauges look normal. The oil and temp gauges don’t sit at 12’O clock when cruising, they sit more around 10/11’O clock. Apparently the thermostat gets stuck open when they fail in our cars causing to it over cool. And It’s not good to drive it w a failed t stat. It would be running rich all the time, and bad mpg. I got my Tstat fixed when I first got my car and I noticed better efficiency immediately. Who ever does the job make sure you order the temp sensor and some extra sets of those ring seals for the T stat housing. I think it was 3 seals total. The seals can break easily when you reinstall the Tstat housing and you’ll be pissing coolant all over the place. Ask me how I know.

That engine sounds great. And I’m really liking that piano black interior trim. I remember seeing this car totaled from your first vid. Props to you for bringing it back to life man it really looks and sounds great. That LMB gets me every time.
It did smell like it was running a bit rich but then again I haven't drove the car long enough to tell for sure. For now I wont be driving the car for at least a week or 2 so I will have to wait and find out I guess. I did have a check engine light that cleared up after a couple starts so who knows maybe it was a code for thermostat warming up long or something. Once I get some stuff sorted out I will scan the car for codes and see if anything changes as I put the first couple hundred miles on her. Thanks for letting me know about the emp sensor and extra seals haha and we always gotta learn the hard way!
 

·
Registered
Joined
·
4 Posts
Amazing work man! LMB paint looks great! Do you mind sharing me the shop who did the paint? I'm also from around Modesto area. How much for a whole car Le Mans Blue paint job? 🤑
 
21 - 33 of 33 Posts
Top