BMW M5 Forum and M6 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
2nd post of today - its too early to be typing!:D
My 55 plate E60 M5 was bought only 6 months ago, from one prev owner and full service history, which seems to have been well cared for. However, my idrive is extremely slow, and at times i can wait 10-15 seconds for any response when i play with the drive knob. Is this common on this age of E60 and can it easily be sorted? I have a comprehensive warranty but with a £100 excess, so I want to avoid booking it in. I hoped that the system perhaps could be reset? I refer to my other thread which asks for help with a parking sensor failure problem. Thank you.
 

·
Registered
Joined
·
111 Posts
Mine is sometimes slow after starting the car, other times it's not. Not sure why.


the computer starts to start up the second you hit the unlock key, thats why when you get in the car and its not even on, you hear the DVD disc being used. the i-drive is sluggish for up to the first 5 minutes after start up "not even though", because it itself is still starting up. should not be sluggish afterwards..
 

·
Registered
Joined
·
94 Posts
I had a 55 plate E60, now I have a 57 plate. The latter's iDrive seems to be quicker. Saying that, the old car's menu didn't take 15 seconds.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
idrive

I forgot to also say that my phone connection works but only recognises a very small portion of the contacts. I have several hundred contacts and they're all outlook on my blackberry so its not as if they're of a different format. Either way, the phone system is used for hands free speaking and that's it.
 

·
Registered
Joined
·
94 Posts
I get a weird phone thing too. If I dial out using the iDrive it will display the name and number, if a call comes in that is in my address book it will just show asterisks. Iput it down to the way my HTC phone stores names; it has a default work, home, mobile that it tags on to the name. So it shows as J Bloggs (M) in the iDrive.

I think it confuses it.
 
1 - 6 of 6 Posts
Top