BMW M5 Forum and M6 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
:confused: Hey guys, I got the SES light, when I am driving, the engine hesitates below 2000 rpm with lumpy idle, but once I get past 2000 rpm, everything seem to run fine

Did a code read, it showed a few occurrences of rich conditions.

I replaced the MAF's recently, along with new O2's, and new plugs

Car is a 2003 M5 with 50,000 miles, full Supersprint header, cats, pipes, mufflers, LTW flywheel, otherwise stock

I erased the code, car drove fine, but about 30 min and the same code came back, and again it hesitates below 2000 rpm

Any ideas/experiences with similar issues?

Your help is greatly appreaciated.

Geoff
 

·
Registered
Joined
·
12,892 Posts
:confused: Hey guys, I got the SES light, when I am driving, the engine hesitates below 2000 rpm with lumpy idle, but once I get past 2000 rpm, everything seem to run fine

Did a code read, it showed a few occurrences of rich conditions.

I replaced the MAF's recently, along with new O2's, and new plugs

Car is a 2003 M5 with 50,000 miles, full Supersprint header, cats, pipes, mufflers, LTW flywheel, otherwise stock

I erased the code, car drove fine, but about 30 min and the same code came back, and again it hesitates below 2000 rpm

Any ideas/experiences with similar issues?

Your help is greatly appreaciated.

Geoff


"full Supersprint header, cats, pipes, mufflers, LTW flywheel, otherwise stock"??
Not exactly "stock". What software are you running? SS headers should lean the car out considerably, so first guess is that perhaps your tuner didn't get the setup correct. Any dyno runs?
Regards,
Jerry
 

·
Registered
Joined
·
34 Posts
Discussion Starter #3
The car is running factory software, I did all the mods myself, do you think software would fix the problem?

Or could this be a vanos issue? which I dread....

Geoff
 

·
Registered
Joined
·
12,892 Posts
The car is running factory software, I did all the mods myself, do you think software would fix the problem?

Or could this be a vanos issue? which I dread....


Geoff
Hmm, factory software + headers = engine BOOM!

You should be running too lean with that setup. I would get some software to compensate for the better breathing of the headers. Powerchip is well ragarded, also Diinan, two of the more popular and well regarded tuners.

Regards,
Jerry
 

·
Registered
Joined
·
12,398 Posts
I wonder if the system is desperately trying to trim the AF due to the higher flows with the headers, and is maxing out the DMEs limits towards rich... not sure if that error is when the engine is running rich- OR- when the DME hits the limit on how rich it can go.

Clearly if there is stock programming, you need to replace the other components to stock as well... Or have it tuned to match the mods!
 

·
Registered
Joined
·
2,323 Posts
DME tunning is needed first. If the problem persist then I would suggest a spark issuue, maybe plugs or coils...

I'm pretty sure PC GOLD 93 should do the trick
 
1 - 8 of 8 Posts
Top