BMW M5 Forum and M6 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Today was a fricken cold day, this morning I went to start the car and turn on the seat warmers and the lights turn on for a second and automatically turn off. Both sides are doing it, does anyone know what the problem could be? Relay or fuse? I need these to work, I froze my *** off today... literally.
 

·
Registered
Joined
·
56 Posts
My money's on fuse 32 (25 amp) being blown. This fuse supplies KL-30 to the SZM (center console switching center) for seat heating use. The SZM also gets KL-R, KL-15 and KL-87 from different fuses which is why the LED illuminates briefly and the DSC and Sport buttons still work.

You should have a spare 25 in the fuse box that you can use for instant gratification, but don't forget to replace it for future issues. As for the root cause? Could be a fatigued fuse that just cracked from years of seat heating curent running through, or a very intermittent short that may never happen again (blown violently), but I'd start by replacing the fuse and seeing how long before it blows again.

Good luck!
 

·
Registered
Joined
·
17 Posts
Discussion Starter #5
Thanks for the detailed information, and everyone's help. I'm going to attempt the diagnoses during lunch.
 

·
Registered
Joined
·
2,367 Posts
I have the same problem on mine, fuse 32 keeps blowing on mine, the element in one of the seats is broken/split, and I am sure not cutting my seats apart to fix that! Hope that's not the case for you but if it blows again real soon, thats prob the case.
 

·
Registered
Joined
·
131 Posts
I experienced this very problem this morning. A quick check on M5Board and I got the solution. I really appreciate the wealth of knowledge offered by this boards membership. Thanks for the post.
 
1 - 7 of 7 Posts
Top