BMW M5 Forum and M6 Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
186 Posts
Discussion Starter · #1 ·
Hi all.

I recently removed the drivers seat from my car to do the "shortening" of backrest & height cable outers.

When I put the seat back, the "Memory" button doesn't work anymore. The button does not light up when it's pressed and it doesn't store new seat positions. I removed the switch to test it and it seems to work correctly.

Switches 1, 2 & 3 work fine with the settings that were stored previously, but I don't seem to be able to change (re-program) them ! :confused:
The globe works. (pins 3 & 4 on the memory switch)
The memory switch LED works. (pins 1 & 5 on the memory switch)
Memory switch pushed - 0 ohms between pins 2 & 6 on the memory switch
Switch 3 pushed - 68 ohms between 2 & 6 on the memory switch
Switch 2 pushed - 180 ohms between 2 & 6 on the memory switch
Switch 1 pushed - 550 ohms between 2 & 6 on the memory switch
Which I believe are all correct.

Does anyone have any ideas why the MEMORY switch would just stop working ? :1zhelp:

Thanks,
Reg.
 

·
Registered
Joined
·
584 Posts
Are the buttons all sticking up the same amount?


When I bought my car, the 1 & 2 buttons didn't work. And the 1 button was almost flush with the button surround, and the 2 button was up just a slight bit higher than the 1 button.

Took the switch apart and found that the PCB had been pushed into the switch too far because the very small amount of plastic that's in there to keep it in it's place had broken off and had allowed the PCB (which is what the buttons are mounted to) to not be seated up as high as it's supposed to. Therefor you couldn't push the buttons down far enough for them to make contact. And that's why they didn't work.

So, I put the PCB back to where it was supposed to be and put two little dabs of epoxy in pace where the little plastic tabs were so as to prevent the PCB from getting pushed too far into the switch.

Solved the problem, and has worked great ever since.

Not sure if this applies to your problem or not though...
 

·
Registered
Joined
·
526 Posts
I have electric seats but no memory buttons. Where are these buttons situated? Can someone post some pics, please.
 

·
Registered
Joined
·
186 Posts
Discussion Starter · #4 · (Edited)
Are the buttons all sticking up the same amount?


When I bought my car, the 1 & 2 buttons didn't work. And the 1 button was almost flush with the button surround, and the 2 button was up just a slight bit higher than the 1 button.

Not sure if this applies to your problem or not though...
Hi Bubba. Thanks for the suggestion, but all 3 "position buttons" work fine. The seat will move to the positions previously programmed. The problem I have is I can't change the positions that are programmed into each button. The "memory" button does work. I connected a multimeter to the contacts and pushed the button. I can see the voltage across the button pins change when any of the buttons (including the "memory" button) are pushed. The "seat memory computer" under the seat, just doesn't seem to recognise the change.

Reg.
 

·
Registered
Joined
·
186 Posts
Discussion Starter · #5 · (Edited)
The memory switch is obvious if it's fitted.

I have electric seats but no memory buttons. Where are these buttons situated? Can someone post some pics, please.
Hi AfricaOffroad.
If the memory was fitted to the seat, you couldn't possibly miss the switch when you opened the car door to get in.

The switch has 4 rectangular buttons, 3 are numbered 1, 2 & 3 and are black with white text, the 4th is red with the word "MEMORY" written on it in white. The switch is located in the top of the plastic "dress panel" attached to the outer side of the seat. You'll probably see a blank fitted into the dress panel at the location where the switch would be fitted.

Reg.
 
1 - 5 of 5 Posts
Top