BMW M5 Forum and M6 Forums banner

1081 - 1100 of 1108 Posts

·
Registered
Joined
·
1,511 Posts
Yup, I got the geek-cable....still scary with all the "brick" talk amongst the 08s and newer...

If anyone is ever in N. Dakota....wait, nevermind, I am the only person in this bimmer-free state....
Ha! For what it's worth I was the guinea pig for the pro cable (08 just like yours). I've flashed both DME and SMG back and forth without any issue. Had to return the DME to US for idle hunting to reappear. I got 4 new vanos solenoids out of my warranty, but since the inspector runs the quality test anyway I doubt the dme flash got me anything. Didn't hurt tho. Before leaving the shop I flashed back to euro DME.
 

·
Registered
Joined
·
1,345 Posts
Yup, I got the geek-cable....still scary with all the "brick" talk amongst the 08s and newer...

If anyone is ever in N. Dakota....wait, nevermind, I am the only person in this bimmer-free state....

LOL if you brick it, I have a spare TCU or can try to recover yours in the name of the S85 Gods for the cost of shipping.

We have to watch out for our remote no bmw friend brothers.
 

·
Registered
Joined
·
22 Posts
Got all reflashed to euro software and adaptations done but one of the adaptations failed, now I've got the dreaded red cog and Clutch!Adaptation active on my screen followed by some rough shifting. Appointment with BMW set for Saturday morning - research says prob a bad slave cyl - hopefully still under warranty but we will see. It's never easy with me. My luck I guess. My boy terraphantm hooked it up though! Thanks again I appreciate it!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,511 Posts
Got all reflashed to euro software and adaptations done but one of the adaptations failed, now I've got the dreaded red cog and Clutch!Adaptation active on my screen followed by some rough shifting. Appointment with BMW set for Saturday morning - research says prob a bad slave cyl - hopefully still under warranty but we will see. It's never easy with me. My luck I guess. My boy terraphantm hooked it up though! Thanks again I appreciate it!


Sent from my iPhone using Tapatalk
Try hooking up a battery charger or power supply. That made all the difference on mine. If you can't, go for a short ride (engine should run above idle for 5 minutes or so to help battery charge) and run adaptations right after shut off. Make sure you set fan and headlamps manually off as well as radio, and close the door (due to interior lights). You can try several times in a row, no harm.

Why did you run the adaptations tho? AFAIK there's no need to do so when flashing euro smg.
 

·
Registered
Joined
·
22 Posts
Had my tranny replaced 4 weeks ago. It was rough shifting a bit and I know in the past that fixed it.

Terraphantm, wanna give it another shot?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
66 Posts
I have a US market 2010 M6, tried to flash with my old cable and it did not work (same error as everyone else got), but I used the "Pro" cable from Bimmergeeks and it flashed without issue.

In my M6, I do now have 4K launch control, but the car still doesn't automatically shift gears. Can anyone else confirm that the gear shift works on an M5, but not on an M6?
 

·
Registered
Joined
·
66 Posts
Tried it again tonight, and it's for sure not shifting automatically. I'd be interested to know if any other M6 owners see the same behavior. I'm using the v60 daten.
 

·
Registered
Joined
·
85 Posts
I just did the euro tune to my 06, in launch control it now revs to 4200 ish but when I let go of the joystick nothing happens just revs higher. So I went through inpa and did trans adaptation over again, I'm going to shut the car off and let it sleep and see if it will actually launch now. Any advice is appreciated
 

·
Registered
Joined
·
6 Posts
Does anyone know if the One Stop Electronics cable will work for 2008+? I was looking at buying the Bimmergeeks cable but if the One Stop Electronics one works then there's no need.
 

·
Registered
Joined
·
4 Posts
Does anyone know if the One Stop Electronics cable will work for 2008+? I was looking at buying the Bimmergeeks cable but if the One Stop Electronics one works then there's no need.
Pretty sure you'll only want to use an ICOM for 08+ or risk bricking the SMG...

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
134 Posts
Been searching around the internet for the SMG euro tune. I have all of the hardware, I already have been coding my E38 and E39. Any ideas on where to find the software other than a tuner?
 
1081 - 1100 of 1108 Posts
Top