BMW M5 Forum and M6 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2,890 Posts
Discussion Starter #1
Hello all..

I have recently changed the background of the oem dashboard and bought it on ebay.com ,, rebuildt,, 150 $ ((brand new from Buchloe was 900 € ))and works perfect.. on the oem i couldnt get water temp and so on.. the fuel meter was also really playing with the needle up and down ,,,ouichouich

But,, the digital gauge -->>
oil heat ## oil press ((bar )) -------boost pressure((bar))### diff heat °c

on the right side were boost and diff temp is ,,,the instrument is hard to see
so i opened it and there are no lights on the bulbs,,((2 of them))
arghhh,, they are welded or whatever you call it and i want to ask you folks out there,, is it anyone who have been in a similair situation,,
maby one of the lines are cracked or damaged .. i will use a ohm measure to find out,, but if not should it be a problem to change these bulbs ??

i hope somebody knows something about it

BEST REGARDS
 

·
Registered
Joined
·
749 Posts
I changed them on CJs car. You have to solder the light off the print. Easy job if you can solder/weld of course. I welded it off and went to an electronic store and got new ones. Changed them and it worked again.

Change them all if you do.
 

·
Registered
Joined
·
2,890 Posts
Discussion Starter #3
I changed them on CJs car. You have to solder the light off the print. Easy job if you can solder/weld of course. I welded it off and went to an electronic store and got new ones. Changed them and it worked again.

Change them all if you do.
Ok,, thats what i thought,,

Thank you ..
 

·
Registered
Joined
·
2,890 Posts
Discussion Starter #4
JUHUUU,,

PROBLEM FIXED..

one of the bulbs,, was not well solded/welded and when i was picking w/ my tiny screwdriver,, bingo ..suddenly LIGHT :1::7:
 
1 - 4 of 4 Posts
Top