BMW M5 Forum and M6 Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
267 Posts
Discussion Starter · #1 ·
So on my quest to get the beast to full power I have replaced the MAFs, air filters, fuel filter and all 4 oxygen sensors. The only thing in that system I didn't touch were the camshaft sensors.

Before touching anything, my car had 78k miles of it and in test 4 second selection ("maf test") it showed peak numbers of 100 l/h. I changed the MAFs and it jumped up to 120s, seeing numbers even as high as 130. After replacing the air filters, fuel filter, and oxygen sensors I felt the car pull harder for the first day but didnt do any tests to confirm new l/h numbers because I was waiting for the ecu to reset. Now, however, 2 days later and my l/h numbers are back down to 100 :Thumbdown:... I have to clue what the issue can be :sad1:

If anyone is in the Atlanta area and would like to take my car with me for a spin to help diagnose the problem I would greatly appreciate it.

Also, if anyone is looking for a great shop in the area that is operated by a fellow board member I highly urge you to consider Alex's shop ( http://www.alexautoinc.com/ ) in Norcross. He helped me with the install of my terribly rusted in oxygen sensors and is a great guy to work with. It has taken me forever to find a shop I can actually trust and now that I have I feel like I must share my secret with my fellow M5 enthusiasts :cheers:
 

·
Registered
Joined
·
267 Posts
Discussion Starter · #4 ·
IMO CPS sensors are important bits.

So are the Vanos Solenoid O Rings.

You could try cleaning out your oil separators too.

Do you have any engine codes ? Have you read your Fuel Trims ? What MAFS did you install ?

PS : You have replaced FAR from ALL the sensors :)
Any way to test the CPS sensors and the Rings easily?

I had the evaporative fuel purge valve code going on and off before putting everything in, the ses light is still on so I will pull the codes tomorrow.

I have not read the fuel trim levels, gonna go do a search on that unless someone has a quick link or explanation handy.

I installed bosche MAFS from beastpower

Spark plugs were changed less than 20k miles ago.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top