BMW M5 Forum and M6 Forums banner

1 - 20 of 21 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
I recently bought a Mark IV unit+DVD EU map disc from ebay. I replaced the Mark III unit and put the DVD disc in and it does not recognize the disc!!!
I replaced the DVD with an old homeburnt CD mapdisc and it recognized it at once. What´s going on? Can somebody help me out here?
I have the old 4:3 display but that should not affect the DVD reader.
 

·
Registered
Joined
·
12,398 Posts
Well, lets assume it is a real BMW Mark 4 and it is in working condition...

Is the DVD a BMW dvd or a copy? Is it for the trunk mounted DVD drive? (the "dvd-ccc"0 disk only works in the dash mount, E90, E60, E63)

SInce it works on the CD but not the DVD I am guessing it is a bad DVD or the wrong dvd...

A

Home burned dvds can have issues- too many minor errors that the cheap, small DVD drive cannot correct. You need to re-burn the dvd using very high quality media and drive. (Yeah, an issue if you just have a disk)
 

·
Registered
Joined
·
2,817 Posts
Prob a long shot, but I just had my MK IV replaced under warranty for the same issue. It would read CD's fine, but not a DVD. Turns out that the cooling fan was inop, necessitating the replacement. Glad I didn't have to pay.

:cheers:
 

·
Registered
Joined
·
39 Posts
Discussion Starter #4
ELEVENS said:
Prob a long shot, but I just had my MK IV replaced under warranty for the same issue. It would read CD's fine, but not a DVD. Turns out that the cooling fan was inop, necessitating the replacement. Glad I didn't have to pay.

:cheers:
It is not a homeburned DVD, I bought it in a bundle with the DVD reader. The issue is 2004-2. I did´nt know that they had different map releseases for different systems. Thought it was the same for all car models.

Did they explain why it would´nt read DVDs and only CDs because the cooling fan was broke?
 

·
Registered
Joined
·
931 Posts
I recently did the similar upgrade to MK-IV. My install required a 'system' software upgrade (separate disk form the map disk). Once done, the map DVD went right in. There did seem to be a half a days worth of realigning to the Sat./NAV map. Initially the map showed me as to be in the relative area of the map, but not on the proper road. The next day all was correct and still right on after 3 months of use.

Good Luck....
 

·
Registered
Joined
·
366 Posts
As I upgraded the same way, I had to do a s/w upgrade prior to using the system for the fist time. Just s/w first, then the DVD and presto. If you are upgrading from an earlier system chances are that's it. I have a copy if you need it. PM me.

-a
 

·
Registered
Joined
·
12,398 Posts
IceGBG said:
... and by the way, what is a "dvd-ccc"0 disk?
How can I tell the difference?
Many thanks
Here's one:

http://cgi.ebay.com/ebaymotors/BMW-On-Board-Navigation-System-DVD-ROM-North-America_W0QQitemZ7990377766QQcategoryZ38653QQssPageNameZWDVWQQrdZ1QQcmdZViewItem

If you look carefully at the text printed on the disk, two lines below the DVD symbol on the left side, you will see DVD-CCC... this disk won't work in ours (trunk mounted DVD unit)

A word to be careful with ebay- some sellers say "works with all DVD nav systems- buyer still responsible for own research"

A
 

·
Registered
Joined
·
39 Posts
Discussion Starter #9
I have now upgraded the Mark IV unit with OS SW v25, but it still refuses to read the DVD. I find this really strange.
Any more suggestions, guys?
 

·
Registered
Joined
·
1,069 Posts
mr_bock said:
There did seem to be a half a days worth of realigning to the Sat./NAV map. Initially the map showed me as to be in the relative area of the map, but not on the proper road. The next day all was correct and still right on after 3 months of use.Good Luck....
Unfortunately, there is no real process to determine how many satellites your navigation system has acquired. Yes, there is the little window with things moving about but is there really a correlation between the dots revolving and satellite reception?

It appears the re-initialization of your system took longer after the new software was loaded hence the reason your vehicle’s location was incorrectly shown on the map. GPS systems normally require a minimum of three satellite signals to properly operate, some will operate in a degraded mode (i.e. less accurate) with two. BMW’s system does not provide the user with any prompts to inform you of this. It also is not uncommon for the first time initialization process to be longer than normal and can become even longer as you move your vehicle around.
Ken
 

·
Registered
Joined
·
2,817 Posts
The "secret setup" will tell you how many satellites that your system "sees", and whether the GPS location is real or "remembered" from last time (such as would be the case when in a garage or tunnel, etc). My system typicall "sees" 8 or 9 satellites.

To get to the menu, with key on and turn off, use the right knob to get into the "SETTINGS" menu. Now hold the "MENU" button down for 10 seconds.

:cheers:
 

·
Registered
Joined
·
1,069 Posts
ELEVENS said:
The "secret setup" will tell you how many satellites that your system "sees", and whether the GPS location is real or "remembered" from last time (such as would be the case when in a garage or tunnel, etc). My system typicall "sees" 8 or 9 satellites. :cheers:
Bill
Thanks, I had forgotten about the secret setup since I only used it right after delivery when I was attempting to get Traffic Advisory activated.

I guess to be more correct, I should have said that the system doesn't provide accurate satellite info once you start your car and attempt to drive away.
Ken
 

·
Registered
Joined
·
2,817 Posts
kwalls said:
Bill
Thanks, I had forgotten about the secret setup since I only used it right after delivery when I was attempting to get Traffic Advisory activated.

I guess to be more correct, I should have said that the system doesn't provide accurate satellite info once you start your car and attempt to drive away.
Ken
True indeed, Ken. I tried getting into the secret setup (there HAS to be a better name for that!) while on the highway this morning and couldn't. So I guess you need to be stopped, perhaps even with key in the "1" position.
Bill
 

·
Registered
Joined
·
12,398 Posts
IceGBG said:
I have now upgraded the Mark IV unit with OS SW v25, but it still refuses to read the DVD. I find this really strange.
Any more suggestions, guys?
What version of SOFTWARE is loaded?

(V25 is the UPGRADE version)

If you go into the Settings menu, the upper right corner should list the SW version. If all is current with V25 and Mk4, you should see:

SW 4-1/50

Not sure what else to say....can you borrow another DVD?

A
 

·
Registered
Joined
·
118 Posts
I didn't have the problem reading the dvd after upgrading but I did have the problem of the GPS not working correctly when driving. But mine was caused by a damaged antenna connector. The one that comes from the back of the unit and plugs into the Antenna lead. I actually took it apart and had the connector removed and a new one soldered in. I was very surprised that I was able to reassemble it correctly and that the guy who replaced the connector didn't fry the trimble gps pcb. But very happy when it worked. The dvd nav unit is so much better than the MkII or MKIII units.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #16
It says SW 4 - 1/50, so I guess the last thing to do is to try with another DVD.
Thx anyway.
 

·
Registered
Joined
·
14 Posts
I have it

If you guys are interested, I just got my hands on a whole bunch of the Latest Map Disc DVD's 2005.2 and V26 Firmware Update. I am selling them on ebay and my ebay name is bigpauly55 if you need to look up my auctions. I have sold quite a few and everyone seems to be happy with it, I even helped a guy from this forum who had a little trouble figuring it out, his name Is Kent from Atlanta and he is another happy customer after walking him thru the install. I'm selling the Map DVD for $100.00 it comes in the DVD case with the pamphlet inside, I tested everyone of them to make sure that they are legit and working. I'm selling the V26 Firmware update for $30.00 with detailed installation instructions and technical support (if needed) also shipping is free on both of items.
<!-- / message -->
 

·
Registered
Joined
·
567 Posts
I have recently been going through this same problem. My dvd was working for several months, now all of the sudden it won't read the DVD, even though it will read the CD's. It says no disk in drive, or error in reading disk. It was fine until I took it in four routine service, now nothing. Of course the dealership says they didn't touch it, and I bought the DVD drive off ebay so they won't help with that part either. The disk is brand new straight from Navtech though. It doesn't appear scratched, and has only been out of the package once, when I put it into the car. I can't figure out how the disk could go bad, unless the service tech took it out for some stupid reason.
 

·
Registered
Joined
·
12,398 Posts
Bigpauly52 said:
They are navtec, at least that's what the DVD and the case and the papers inside say.
Uh huh. Do they have a serial number on the disk? It is engraved on the disk on the side OPPOSITE the printing...around the hub.

If your discs have no serial data they are counterfeit.
 
1 - 20 of 21 Posts
Top