BMW M5 Forum and M6 Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
222 Posts
Discussion Starter #1
Can someone please help me. Ive searched threads on the board and have found different opinions. It seems like a lot of people have had this problem yet there is nothing confirming a solution or fix to the problem. I have tried ashoks method to take out the battery and remove the 2 fuses but that did not work for me.
My navigation screen looks scrambled and the radio cuts out after 2 minutes. My orange light works, even though the radio will cut out after 2 minutes the song will continue to play until I turn the radio off and back on again to get the sound back on.

Please help me find what I need to do to fix this problem. Is it the radio, the nav box in the trunk, the dsp amp?
Thank you for your time guys.
Any advise is greatly appreciated.
 

·
Registered
Joined
·
6,940 Posts
^^^ What he said, or your Nav drive. Try swapping one out with another member in your area......
 

·
Registered
Joined
·
3,183 Posts
Would it be possible to post a picture of the Nav screen that's 'scrambled'.

The Nav (or more accurately the Graphics Driver) sends a message to the DSP amp every 50 seconds or so, if the DSP amp does not see this message it will cut out - no idea what the design idea was behind this, may be power saving if something goes wrong while the ignition is off? So, if the Nav computer goes down for some reason the DSP amp will shortly follow unless you also have the TV module (which takes over as the graphics driver if it does not see a message from the Nav for 60 seconds).

It may be worth removing the map disc from the Nav, disconnecting the Nav computer from the blue and purple connectors (wait until the light goes out if it's a MK III), leave the Nav disconnected for 15 minutes, then connect back up. Leave the map disc OUT. See what happens.
 

·
Registered
Joined
·
2,271 Posts
I have similar sorts of issues with mine, was using the nav to drive 250 miles on Boxing Day, and suddenly the screen went blank. CD kept playing, but all buttons on the headunit were unresponsive. Pulled into services and turned the car off. When I restarted it it, I had a proper old, blocky, Ceefax-style display. Turned it off in disgust. Next day, restarted it and it was back to normal (latest firmware display on the Mk3). It has since done the same thing exactly while not using the Nav, yesterday, I set off to Nottingham at 05.00 and realised I had no CD playing. The amber light was on, went into the menu and selected a CD and it was as though it was taking ages to find it. Put the screen to the OBC, and on the way down, the csreen again went blank and was unresponsive. Turned off and back on in the services, and it came back to normal, and could listen to CD's again.

I have a 'non-standard' map CD in the drive and thought it might be this, perhaps not as it's done it since when not using the Nav.

If a search for solutions shows it be the Mk3 nav unit, I may just swap out for a Mk4, although the only ones on eBay at the moment are from Lithuania, and I'm not sure I want to send £400 abroad on the off-chance.

Has anyone bought one of the ones from Toyinyourcar, I imagine they may carry some sort of warranty, even though they're not new.

EDIT - OK, searched on recommended phrase, and it seems my flat battery over the snowy Christmas might have caused it. Guess I'll just bite the bloody bullet and buy a new one... Could've done without that just at the mo, as I have various mechanical bits that need doing.
 

·
Registered
Joined
·
222 Posts
Discussion Starter #7
Thanks to everyone for their replies. I will take a picture of the screen and post it on the board later today. So the so the radio and screen not working could be the failure of one device? And in my case if the nav unit in the trunk is bad will it cause both of these symptoms?

Thanks again everyone
 

·
Registered
Joined
·
222 Posts
Discussion Starter #8
Here is a picture of the screen.
 

Attachments

·
Registered
Joined
·
345 Posts
Spoolin51: Resounding YES!!!!!! I am happy to report that replacing the Nav computer with a known good MKII unit this afternoon has solved my scrambled/dead nav screen and radio cutout problem. Ok, so it's not as nice as an upgraded MKIV unit with the 16:9 screen, but for now I can listen to music and make use of the Nav if necessary.
 

·
Registered
Joined
·
222 Posts
Discussion Starter #10 (Edited)
Spoolin51: Resounding YES!!!!!! I am happy to report that replacing the Nav computer with a known good MKII unit this afternoon has solved my scrambled/dead nav screen and radio cutout problem. Ok, so it's not as nice as an upgraded MKIV unit with the 16:9 screen, but for now I can listen to music and make use of the Nav if necessary.
Man thats awesome. I'm glad that worked out for you. So basically you replaced this item BMW E38 E39 M5 NAVIGATION MK2 740i 740iL 750iL 540i OEM - eBay (item 140495241487 end time Jan-28-11 09:19:54 PST) correct?
 

·
Registered
Joined
·
2,271 Posts
I got the firmware downloaded last night, I already have the latest (63 I think it was) but will burn tonight and flash to see if this makes it any better.

To be honest, if it does eff the unit, it's not all bad, would just lose out on selling the old Mk3 on ebay, but they don't seem to make a lot nowadays.

Will report back on how it goes.

Glad to hear the OP got their issue btw!
 

·
Registered
Joined
·
345 Posts
Well, I'm not 100% positive that that particular Nav computer will work. I have a hunch that that one came from a E38 7 series, which MAY work, I'm just not sure. The part number for our cars is 65.90-6 908 309. The one in that auction is 65.90-8 386 849. Again, it MAY work, it looks identical to ours right down to the color coded plugs in the back, but I'd make 100% sure before you shell out that kind of money. Check out this very helpful pdf file and make your decision based on that:
http://www.bimmerboard.com/members/jcarey/BMW Navigation Buyer Guide.pdf

Good luck.
 

·
Registered
Joined
·
3,183 Posts
An E38 Mk II should work perfectly well in an E39, but that MK II is crazy money!

A Mk II should be about $100, they are not worth more than that, you should be able to get a MK III easily for $350.
 

·
Registered
Joined
·
769 Posts
I'm having the same problem. Did the Ashok fix but it did not work. The (sound)radio stops working and screen is blank but the orange light is on. How/where can I get firmware update?
 
1 - 14 of 14 Posts
Top