BMW M5 Forum and M6 Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi all, I apologize in advanced if this has been covered already, but lately I have been having issues with the radio and nav screen:

Screen: No information is showing up at all. I can see that its illuminating as if its on, but there is no info, which makes it impossible to access anything.

Radio: This is weird, the radio plays, but only 3-4 minutes at a time, then it just cuts out. If I turn the car off, and back on, the radio will play again for a few, then cut out again.

Any ideas as to why this is happening or how I can resolve this? Do I need to take it to dealer for help? Thank you very much.

Regards,
Paulo
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
So you're saying the unit in the trunk is what's causing the screen to not display info? Ok, gotta check to see if I can find one of those, how much did that run you if you don't mind me asking, thanks for the help.
 

·
Registered
Joined
·
2,271 Posts

·
Registered
Joined
·
137 Posts
So you're saying the unit in the trunk is what's causing the screen to not display info? Ok, gotta check to see if I can find one of those, how much did that run you if you don't mind me asking, thanks for the help.
It's been a while, but I think ~200. Depends on what model you need.

It sounds strange that it would affect the screen, but that's what fixed my problem and it was identical to what you describe. Even with the audio cutting out after a few minutes.
 

·
Registered
Joined
·
2,271 Posts
Might be worth trying the reset on the nav unit first before buying another unit, as per that thread I posted. Apparently it could also be the radio unit too, you could ask if anyone else in the NY area has a spare nav or radio unit for you to use to test before forking out :)
 

·
Registered
Joined
·
3,177 Posts
It's not strange that it effects the screen at all, the Nav computer contains the graphics driver that generates the picture that's displayed on the screen, the Nav and monitor are connected via an RGB signal. It's like saying it's odd that my monitor goes blank when I turn my PC off! :)

The radio also requires a keep awake signal from the Nav computer, that's why it goes off after a couple of minutes.

In a few cases you can resurrect the Nav by disconnecting it and leaving it for a while before re-connecting it. However, you should remove the Nav if you can't resurrect it as it could flatten your battery.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
Thanks for the replies guys, I am gonna try the simple methods first to see what happens, hopefully its a simple fix, with my luck it never is though.
 

·
Registered
Joined
·
3,169 Posts
I had this same exact problem, shafro. New nav computer in the trunk fixed it. Mk3 should be had for around $300.
 

·
Registered
Joined
·
3,169 Posts
Up to you. Just wanted to let you know that I solved my issue with a new nav computer, like most other people I know.
 
1 - 13 of 13 Posts
Top