BMW M5 Forum and M6 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I just changed the clutch on my 2006 M5 with 63k miles. I am having major delays while driving. The indicator will change gear but the car does not move. Feels like the car is stuck in neutral with the rpm going up. Theres about 5+ second delay before the car starts pulling. I've tried a SMG reset on the highway putting the car in neutral and pressing down on both paddles. Anyone know what the problem might be?
 

·
Registered
Joined
·
410 Posts
I believe the dealer does some sort of clutch learning procedure when the clutch is changed. If you changed it yourself and don't have the dealer diagnostic system, you need to take it somewhere to have this done.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
SepangM5 - I don't have enough posts to reply your PM.
I had my clutch changed at a local shop in Brooklyn.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #4 ·
anyone have this problem after changing their clutch? 1st gear is fine. shifting into other gears will have heavy delay with rpms going up but car not picking up speed.
 

·
Registered
Joined
·
300 Posts
I'm pretty sure there is a "teaching" procedure that a dealership tech has to do after a clutch change that extends beyond what you can do without a GT1 tool.
 

·
Registered
Joined
·
205 Posts
I believe the dealer does some sort of clutch learning procedure when the clutch is changed. If you changed it yourself and don't have the dealer diagnostic system, you need to take it somewhere to have this done.
Correct. You have to teach the SMG all over again. This procedure probably wasnt done properly.
 
1 - 8 of 8 Posts
Top