BMW M5 Forum and M6 Forums banner

Playing with pixels

1330 Views 14 Replies 10 Participants Last post by  Burnout_187
When i bought my M5 i hated that i had some missing pixels. Well, week ago i ordered new ribbon cable and today we change it with Vantaam5.
Its PITA to change, but yes we did it. Took about 3hours. One cluster left to go, i think that we will make it in couple of hours ouich

Drilling the cluster was pretty intresting :D Here is couple of pictures.


Cluster ripped apart



LCD panel and old "glue" from old ribbon. Taken it away a littlebit.



New ribbon cable attached to cluster.



And tadaa, pixels are back!
1 - 15 of 15 Posts

· Registered
Joined
·
6,659 Posts
Sounds like you are doing more than one cluster. How long did the first attempt take, and how long for the last attempt? Any pictures of this drilling? Thanks.

Took us about 3 hours....

We still have to do my cluster soon.
Not really looking forward to do that again...

Can take a few more pics then...

The drilling part is not easy and also quite some more things that can go wrong during the procedure.
Like cracking the LED display,needles fall of,attaching the ribbon wrong and repeat the procedure.

The ribbon came with quite good instruction and pics,was less than 50$ parts...
 

· Registered
Joined
·
788 Posts
Looks great!!!:applause:

You are braver then me.
 

· Registered
Joined
·
4,923 Posts
I hear the needles are the bit*h of the job. Can you guys verify that?
 

· Registered
Joined
·
4,923 Posts
Ahhhhhhhhhh got it, light dawns on stone henge.
 

· Registered
Joined
·
57 Posts
subcribed
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top