BMW M5 Forum and M6 Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter #1
I have a problem with the PDC on my MY2002 car (front and rear PDC), when I activate it, it beeps a few times and the PDC light flashes. I assumed it was just a single sensor failure, but now i've had chance to test it it seems the entire system isn't working :(

I've had a look, but I can't see a fuse for the PDC (and all my fuses look fine anyway), I've tried pushing all the sensors in but still no luck. I assume there's some kind of control module for the PDC somewhere, maybe it's that that's gone?

If anyone could give me any ideas on what to try next that would be great :)
 

·
Registered
Joined
·
50 Posts
I think I saw the PDC control unit in the fuse section at the back of the car (on the right hand side of the boot behind the fold down panel.) IIRC there's a box with PDC written on it on the left of that space.

Cheers

Alastair
 

·
Registered
Joined
·
797 Posts
Beepcake said:
If anyone could give me any ideas on what to try next that would be great :)
It's probably one or more sensor eyes. I doubt if the electronics downstream of the sensors are faulty.

I had the same problem about a month ago. The BMW master tech ran some kind of diagnostic on the sensor and was able to determine which sensor was bad. Luckily, it was one of the rear sensors on the black trim moulding so the replacement sensor eye didn't have to be painted.

Good luck.

Jeff :cheers:
 

·
Registered
Joined
·
56 Posts
Discussion Starter #4
x703jko said:
It's probably one or more sensor eyes. I doubt if the electronics downstream of the sensors are faulty.

I had the same problem about a month ago. The BMW master tech ran some kind of diagnostic on the sensor and was able to determine which sensor was bad. Luckily, it was one of the rear sensors on the black trim moulding so the replacement sensor eye didn't have to be painted.

Good luck.

Jeff :cheers:
I thought if one sensor went then the system would carry on working with the other sensors but "warn" me there's a fault?

I've found the PDC box in the boot, but there's no sign of a fuse.
 

·
Registered
Joined
·
1,079 Posts
Beepcake said:
I thought if one sensor went then the system would carry on working with the other sensors but "warn" me there's a fault?

I've found the PDC box in the boot, but there's no sign of a fuse.
One way to see if the sensor is emitting an ultrasonic sound or not, is to put the car in ingition II, (so the lights and everything are on, BUT engine not started), put it into reverse, then place ya ear directly next to each of the sensors, there should be a clicking sound from each...

Not sure how the front PDC works, never seen it in person.

Cheers
Tin
 

·
Registered
Joined
·
56 Posts
Discussion Starter #6
Tin said:
One way to see if the sensor is emitting an ultrasonic sound or not, is to put the car in ingition II, (so the lights and everything are on, BUT engine not started), put it into reverse, then place ya ear directly next to each of the sensors, there should be a clicking sound from each...

Not sure how the front PDC works, never seen it in person.

Cheers
Tin
Excellent, I'll look like a bit of an idiot in the office carpark, but i'll give it a go :)
 

·
Registered
Joined
·
1,079 Posts
Beepcake said:
Excellent, I'll look like a bit of an idiot in the office carpark, but i'll give it a go :)
cool, don't forget do not start the engine! otherwise u may need more than a pdc sensor! ;)

idiot? haha not as much as i do cleaning the supersprint tail pipes out in teh drive.. neighbours must think i'm crazy! :p lol
 

·
Registered
Joined
·
56 Posts
Discussion Starter #8
I've just been crawling all over the carpark and one of the rear sensors is not working, the others are clicking away happily though. Unfortunately it's one of the coloured ones, but I do have a spare black one at home, does anyone know if they are a quick remove/install? If they are I might put a black one in to get the system back up and running until I get chance to book it into the dealer.

Thanks for the help!
 

·
Registered
Joined
·
797 Posts
Beepcake said:
I thought if one sensor went then the system would carry on working with the other sensors but "warn" me there's a fault?
The constant beeping in the cabin is a sign that the system has a malfunction. Jeff
 

·
Registered
Joined
·
1,079 Posts
Beepcake said:
I've just been crawling all over the carpark and one of the rear sensors is not working, the others are clicking away happily though. Unfortunately it's one of the coloured ones, but I do have a spare black one at home, does anyone know if they are a quick remove/install? If they are I might put a black one in to get the system back up and running until I get chance to book it into the dealer.

Thanks for the help!
The corner ones are fairly easy to replace, the black plastic corners, pop up and away, there's a small indent that a flat blade screwdriver (wrapped in soft cloth) can pry open.

But the centre's, I'm fairly sure involve the rear bumper being removed. :grrrr:
 

·
Registered
Joined
·
6,354 Posts
My PDC doesnt work as well, it used to beep before, now it only "ticks"! Took it to the dealer and they said the control unit needs to be replaced... i said screw it!
 

·
Registered
Joined
·
1,079 Posts
Ahmed said:
My PDC doesnt work as well, it used to beep before, now it only "ticks"! Took it to the dealer and they said the control unit needs to be replaced... i said screw it!
you could always try sourcing the module from somewhere like a scrap dealer, doesn't have to be from a M5.. any E39 pdc control should in theory fit...

you can try www.fabdirect.com (although based in the uk), they may ship internationally.

or alternatively, on ya next trip abroad, get one from a dealer and make sure of the currency exchanges! :p

Tin
 

·
Registered
Joined
·
9 Posts
Hello,
I have e39 m5 from 2000. I want to retrofit a pdc system, but i read here that some have activation switch on the car? Does it on a e39 or e52? Because the retrofit kit does not include switch it's plug on rear light.
thx.
 

·
Registered
Joined
·
6 Posts
pdc not working need help

all my sensores are making noises but still my light is PDC light is blinking on the dash but does not beep when close to objects...
 

·
Registered
Joined
·
1,872 Posts
OK the system works like this, when you have a sensor failure the system signals this with a long beep and the PDC light flashing.

The other sensor will stop reporting while the light is flashing meaning that the system is not working correctly.

When you take it to your mechanic they can plug in a diagnostic machine that will pinpoint the failed sensor and replace it.

Sometimes you can have an intermittent fault and the PDC will emit a long beep to show sensor failure but may then come back on and the remaining sensors will continue to work, but unless you know which sensor has failed you may hit something unexpectedly as you are never going to be sure as to which sensor has failed until you have it diagnosed!!
 

·
Registered
Joined
·
6 Posts
ASC not working

could some one tell me why ,,the ASC automatic stability control lights is on on the dash board and how could i fix it (i have a 5 series 520i 2002 year model)
 

·
Registered
Joined
·
232 Posts
Same problem here. My PDC isn't working at all and hasn't been as long as I've had the car.

I don't have a PDC button, which seems to be normal with rear only PDC, but what I'm wondering is, that I only seem to have 4 black PDC sensors on the rear bumper and no colored ones. Is that the norm for older E39's ?

As for the faulty PDC, be it the module or the sensors, I guess I've got either get my BMW scanner module working or find somebody, that can plug in for me.

/M
 
1 - 18 of 18 Posts
Top