BMW M5 Forum and M6 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
hi boys, need some help if poss, nearly every time i start the car it over revs i turn it off try again and it revs ok, does not rev quite so high when hot but the problems still there By the way if anyone who was at the last meet remembers the hot rod it only cost me 26 quid to sort the sls
 

·
Registered
Joined
·
1,166 Posts
gary morgan said:
hi boys, need some help if poss, nearly every time i start the car it over revs i turn it off try again and it revs ok, does not rev quite so high when hot but the problems still there By the way if anyone who was at the last meet remembers the hot rod it only cost me 26 quid to sort the sls
HI!
Do you mean that the car revs without giving it any throttle at start?
In that case I would suspect Throttle wire thats stuck(check the throttle position in the engine bay before start)
What car do you have? 3,8 or 3,6?
Could be something in the electronic bits also but can`t really help you there. Somebody else?
But it definitely sounds like that the throttle is open or gets opened at start, otherwise it wouldn`t rev that hard, or would it?

:confused:
Sakke
 

·
Registered
Joined
·
1,934 Posts
I had a similarish problem when the car was hot the engine revved high on idle - got a new O2 sensor - hey presto fixed.

Rgds

J
 

·
Registered
Joined
·
609 Posts
Have your shop check the Trottle position switch. If it's starting to go it can lead to all kinds of funky problems.

Regards
 
1 - 4 of 4 Posts
Top