BMW M5 Forum and M6 Forums banner

1 - 20 of 33 Posts

·
Registered
Joined
·
94 Posts
Discussion Starter #1
Greetings All,
Need some help trouble shooting this issue..
2001 M5 with 88k.
My wife has been driving the car for about the past year or so (yaa, yaa,,I don't want to hear it).
Just the other day I noticed some oil on the ground under the engine area, passenger side..Upon further investigation, I notice some oil around are the airbox where the intake connects to the airbox. I went ahead & opened up the airbox only to find that the K&N filter was saturated with oil. I pulled the filter & notice a nice puddle of oil at the bottom of the airbox & that was what eventually made for the oil on the ground.

I did some searching on the forum & seem to think in is vanos related....The MAF also had oil in it & the oil separator hoses are pretty soft from the oil.
The car runs fine, NO dieseling..Pulls easily to red line without any hesitation....

What to do?

Any insight would be greatly appreciated.
 

·
Super Moderator
Joined
·
4,850 Posts
Look at replacing oil separators, associated hoses, then search/read-up on "gauze" together with "vanos". Assuming your oil level was fine, something aforementioned could be plugged. After that's addressed, your MAFS/filter will likely need cleaning/replacing (suggestion: go with OEM parts).
 

·
Registered
Joined
·
6,642 Posts
Check/replace the hoses and clean or replace the separators as suggested.

It will turn out most likely as a Vanos issue,means clogged bore in the unit or the O-rings between Vanos unit and chain cover went bad...

Do not drive it that much anymore,the oil can destroy the cats.

Also you should change the spark plugs after the issue is solved..
 

·
Registered
Joined
·
94 Posts
Discussion Starter #4
Vantamm5,
Thanks for you input...In reading up on this, I was hoping that you would respond...
Is the O-ring update kit the Dr. Vanos sells what I need to solve this problem?

What is the best method of cleaning the oil separators or should i just replace?

Thanks,
 

·
Registered
Joined
·
512 Posts
Vantamm5,
Thanks for you input...In reading up on this, I was hoping that you would respond...
Is the O-ring update kit the Dr. Vanos sells what I need to solve this problem?

What is the best method of cleaning the oil separators or should i just replace?

Thanks,
Just wait when member Sipi is coming and telling his story about this kind of issue :) (Ok, it was VantaaM5 who did fix the Sipi's car, but still)
 

·
Registered
Joined
·
911 Posts
Vantamm5,
Thanks for you input...In reading up on this, I was hoping that you would respond...
Is the O-ring update kit the Dr. Vanos sells what I need to solve this problem?

What is the best method of cleaning the oil separators or should i just replace?

Thanks,
You can clean separators with brake cleaner. Just spray inside. There isnt nothing inside.

Here is cutted separators with lots of s*hit.

 

·
Registered
Joined
·
6,642 Posts
The Dr.Vanos O-ring kit is for the solenoids.
They have a different shape to the original ones.I do only use the original ones.Way cheaper and have the correct shape.

The solenoid O-rings will not solve your issue...
 

·
Registered
Joined
·
94 Posts
Discussion Starter #8
Ok, got the parts & change out the oil separators, hoses, air filter. Cleaned the MAFs, intake & airbox along with cleaning the oil that was in the plenum...Put everything back together, running fine & will monitor the intake & air filters for evidence of oil.

I went ahead & cut open the oil separators, they didn't look gubbered up like those in Burnouts photo.

Hopefully I can avoid changing out the vanos..
 

·
Registered
Joined
·
100 Posts
It will turn out most likely as a Vanos issue,means clogged bore in the unit or the O-rings between Vanos unit and chain cover went bad...
Can you elaborate on this? I am having trouble understanding how the vanos can affect the crankcase oil pressure.
 

·
Registered
Joined
·
25 Posts
Hm, i have one question. If theres oil in the bottom of the airbox(under the airfilter as i understand it), in what way could the separator be the reason for this?
i'm confused.. the intakes should be air tight so the only way in is through the intakes in the front behind the bumper, correct me if i'm wrong.
 

·
Registered
Joined
·
94 Posts
Discussion Starter #11
I went out & checked on things this morning after my wife has been driving the past 2 days (100-125 miles). I did notice again, that oil has started to make its way down the intake, through the Maf & just a smidge of oil on the filter...No oil through the underside of the filter..Most of the oil buildup was just beginning to accumulate where the intake meets the airbox.

The abundance of oil found when i first discovered this issue, could have been over a few months of running...

Thanks again for everyone's insight.
 

·
Registered
Joined
·
1,782 Posts
Hows your oil level? one time i swear i checked my oil and found it half a liter low, so i put in 1/2 a liter and the next day i noticed oil on the ground. Checked my oil level and it was probably 1/2" over full so i changed it out and never had the problem since. Something to check, mine leaked out the driver side air filter lol.

It was scary, knock on wood it hasnt come back so im not too concerned. Ive done a bunch of maintenance stuff since then, so maybe i even fixed it. After that i did new seperators, hoses, and vanos parts.
 

·
Registered
Joined
·
6,642 Posts
Vantaam,
So are you suggesting that I have the vanos units replaced?
Hell no!!!!!!!!!!

Only if you feel throwing 5k$ on them.

Usually they have clogged bores(found in the last car that had that issue a huge piece of silicone gasket in the bore).
If the bores that return the oil in the crank case are clogged,the oil is released in the plenum.

The units have to be taken out and cleaned,all O-rings(for solenoids and units replaced,lock rings and washers for oil pumps replaced).

Part costs are about 100$.Just quite some work to do the job...

How much knowledge do you have working on cars?

Are there any Vanos error codes stored in the ECU?
 

·
Registered
Joined
·
797 Posts

·
Registered
Joined
·
348 Posts
looks very familiar to me.. so far, like you, i've only changed the solenoid rings. but due to the lovely weather we're having (not), i haven't been able to put much mileage on the car to test it out.
 

·
Registered
Joined
·
94 Posts
Discussion Starter #20
Jdazz,
Thanks for the pics...Looks identical to what I have going on...However, the underside of the top of the cover doesn't look as bad as yours.

Vantaam, I have some mechanical knowledge, I can handle oil changes, brakes & rotor changes and other basic upkeep.
How involved & how much expertise is required for this job?

I really appreciate your help...Thank you..
 
1 - 20 of 33 Posts
Top