BMW M5 Forum and M6 Forums banner

261 - 280 of 310 Posts

·
Registered
Joined
·
4 Posts
I have been down almost the same road as you. I purchased a 2006 M5 without an engine. Rebuilt it & just getting Vanos problems corrected.
My transmission sensor harness had similar problems. I had to rebuild mine from plug to valve body connector. Had to replace my fuel pumps they were frozen, SMG pump was frozen also. SMG pump has to run & put transmission into neutral & disengage clutch before DME will crank engine. If you have good scan tool to monitor DME terminal 15, will help you tremendously.
 

·
Registered
Joined
·
253 Posts
Discussion Starter #264
So looks like the ebay smg controller I got is no good. Put it into my other car that runs fine and it showed track 6/7 error. So now to find another box.
 

·
Registered
Joined
·
253 Posts
Discussion Starter #268
I am running adaptations. So we have the following combinations:
Good car, with good smg controller, runs normal.
Good car, with problem child car smg controller, shift track 6/7 error when I try to run adaptations/throws error code.
Problem child car, problem child smg controller, shift track 6/7 error when I try to run adaptations.
Haven't run problem child car, good smg controller yet (I'm chicken to have an issue with it and take the other car down).

Also the springs look to be blue as well. Dinan springs maybe? The damn struts on the problem child car leak too.
 

·
Moderator
Joined
·
2,089 Posts
Sure sounds like an ecu problem. The one ecu I've seen with issues had water damage. I didn't notice at first but upon closer examination there was some corrosion on the connector pins. When I opened the cover even more corrosion was found. Donated it to a good cause lol...
 

·
Registered
Joined
·
4 Posts
I had ecu with same water damage. A lot of errors & wouldn't crank engine. Can smg controller be reflashed?
 

·
Registered
Joined
·
253 Posts
Discussion Starter #271
flac, you mean SMG controller issue (not ECU-->DME) correct?

Ron, yes, I have reflashed it to Euro spec. The SMG controller is not VIN specific.
 

·
Registered
Joined
·
555 Posts
umm did we determine your SMG controlled was f*cked 2 months ago in this post?

Based on that I thought you sourced or were sourcing another one. No way to salvage that turd. Perhaps you just merely tried with the known good module on your other "good" car. Problem with that is the adaptations are for the other "good" vehicle so while you can start the bad car, but if you don't do adaptations I don't think you can cycle through the gears. And if you did you had issues with the wiring harness anyways. Is that correct? Just trying to see if I follow where you are at.
 

·
Registered
Joined
·
253 Posts
Discussion Starter #276
I think I got on wrong track with harness from crappy smg controller. New one Monday. Tried to upload this earlier.
940564
 

·
Registered
Joined
·
555 Posts
You’re milling the SMG controller? What kinda of mod is that?? Was the wiring indeed bad or was there a problem with the module that was causing the wrong pressure to be reported? Still confused.
 

·
Registered
Joined
·
253 Posts
Discussion Starter #279
Got a new connector from Newark, we'll see how that works and if I can bring this thing back from the dae-ed...
 

·
Registered
Joined
·
959 Posts
Probably more than just a connector issue, right? Usually you don't get that kind of copper oxide without saltwater being the conductor.
 
261 - 280 of 310 Posts
Top