BMW M5 Forum and M6 Forums banner

1 - 20 of 240 Posts

·
Registered
Joined
·
200 Posts
Discussion Starter #1
Hello, and happy corona virus everyone.

As part of my typical day to day foolishness, I bought a new project (yeah, not needed) 06 SMG M5. Had it shipped from CA and it just showed today.

Black/black...and the fun part, it doesn't start.

It cranks fine, coughs a bit, then just keeps cranking. Seems like it needs fuel, but I could be wrong.

I did synch the CAS/DME and it is not the problem. Will add pics soon.

Any ideas on where to start are most welcome!
937081
937082
937083
 

·
Registered
Joined
·
943 Posts
My crystal ball is telling me it's gonna be catastrophic - someone clearly had it apart before (both airboxes were taken out, jump point cover missing, coil packs missing pull handles, the middle clip between the cabin filter housing is gone etc) and didn't like what they found. I'd boroscope every cylinder as the first order of biz.

Fortunately CL is full of $6-8K engines these days.
 

·
Registered
Joined
·
296 Posts
Umm..I’d start by reading the codes, do you have Inpa or Ista/D? If you don’t get some one who has the BMW diag. software


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
586 Posts
Oh boy.. another 06 SMG.. Hope you come out of this a winner. Goodluck!
 

·
Registered
Joined
·
218 Posts
Aside from the obvious price reasons... why go with an 06 ? Prob could have picked up a low mileage ‘08 to ‘10 with small damage on Copart car auctions
 

·
Registered
Joined
·
200 Posts
Discussion Starter #8
Don't see any codes related to engine. Some dsc stuff, but nothing engine wise. So kind of odd code wise.
 

·
Registered
Joined
·
296 Posts
Don't see any codes related to engine. Some dsc stuff, but nothing engine wise. So kind of odd code wise.
You could have fuel system or smg codes..they should show up with the bmw diagnostics software...they might not show up if you are running a generic scanner


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
200 Posts
Discussion Starter #10
I'm running inpa. Was running DrGini, but it seems to have deleted itself off my win10 laptop (wtf??!!!)
 

·
Registered
Joined
·
218 Posts
Check engine ground and the fuel pump relay in glovebox and the 6 or so relays/fuses in ECU box under passenger air filter? Theres only one small ground On the passenger side which can go bad really easily especially if there is any power steering fluid leaks. Its kind of hard to see from top

Due to age and possible high mileage, i would stArt from the relays, fuses, and then move on to checking the engine harness. Someone was already fiddling with it as i can see from the pictures around the fuel injector plugs etc

Just to be on safe side, i would bolt an extra ground wire from the chassis jumpstart ground bolt to the engine block (theres existing ground point Bolts under the plastic cover where the engine harness plugs into and crankshaft sensors are).
 

·
Registered
Joined
·
417 Posts
I'd check spark or coil impulse with an oscope. If the engine is indeed turning over, it is either lack of spark or fuel. I believe in this generation of controller security, the DME/CAS handshake already occurred and would not allow continued crank, if the modules and key failed handshake. That would also set a code for sure, whereas starting your car with 10 defective coils may not generate any code. Also check to make sure the ionic modules are there and hooked up. When you buy non running cars, alot of times parts are missing, ask me how I know...
 

·
Registered
Joined
·
1,017 Posts
Old gas perhaps? Spray some ether in that sucker!
 

·
Registered
Joined
·
200 Posts
Discussion Starter #16
Tried brake clean on start, no joy..will try that again when I remove airbox. If DME/CAS don't synch, it will just crank. Had that happen on my 08. I do have an oscope and current probe so I'll check firing of coils. Didn't see fuel pressure data in INPA, so what's best way to check that? I do have a fuel gauge that's set up for my Ducati, could adapt that I would guess. Ionic modules are there/hooked up. I did go through rear fusebox and continuity check all fuses (good). Not sure what relay is in rear fuse box but didn't mess with that. Battery is low (40% on charger) but car cranks ok.
 

·
Registered
Joined
·
2,385 Posts
battery that low might be the issue. I would fully charge it first and try again before going further.
 

·
Registered
Joined
·
417 Posts
There is no schrader valve so your gauge won’t be of much use. It’s a returnless system with a pressure transducer on the line. I’ve never looked but there should be a procedure to view fuel pressure.

I doubt that anyone would sell an M5 for cheap because of a simple thing like low or bad fuel, blown fuse, dead or low battery, etc. Maybe he’s gonna be lucky though, it could be there are no spark plugs?
 

·
Registered
Joined
·
218 Posts
how do the sparkplugs look?

weird thing is how not a single coil has a plastic handle...

also, do you hear the pumps priming when you just open your car? Its hard to miss...
 
1 - 20 of 240 Posts
Top