BMW M5 Forum and M6 Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hey guys,
I just purchased a 2007 M7 SMG a few weeks ago. The car needs some work and I'm sure I'll find lots of info on here.

As of now, the car doesn't start, even with a new battery. I just hear a click, but no start.

I come from the E46 M3 world. I built a few race cars and raced for many years, so I'm for sure doing everything myself.

Here are pictures of the M6 and my old race car.

Cheers!
936677
936678
936679
 

·
Registered
Joined
·
88 Posts
Fun times, I just bought one myself. Did I see yours online when I was looking? Beware, if car has been sitting a while, the differential may make some grinding noise. They need to get lubed up well, and need an additive to help keep that lube stay on the clutches when the car has been sitting a while. Just found this out the hard way. Thought I had a major problem on my hands.
 

·
Registered
Joined
·
943 Posts
Nice monster - did you have the frame redone in gold?

Edit: your garage set up is bad ***, just noticed the chairs and engine block coffee table.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
Nice monster - did you have the frame redone in gold?

Edit: your garage set up is bad ***, just noticed the chairs and engine block coffee table.
Thank you,
I got the Monster like that. Paint doesn't look original, but I like it.
The coffee table is a S54 motor. The block exploded when I hit a wall after a high speed brake failure.
 

·
Registered
Joined
·
88 Posts
Thank you for the TIS!
I'm not having any issues with the diff, thankfully.
The car goes into limp mode after a few minutes, though.
Good times...
BTW - its not really an additive, its just thicker diff oil. just switched to it a week back. easy to do, its running much smoother now.
 
1 - 10 of 10 Posts
Top