BMW M5 Forum and M6 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
So I just bought my first 5 series.

An e34 M5.... 1990, it came over from Japan.

<!--StartFragment -->VIN: WBSHD910X02899604 (VIN DECODERS?)

Can anyone tell me where this car originated from? What is special or different about it compared to USDM cars?

I brought it to the local BMW dealer to get the valve adjustment and fluids changed out. Driving it there it seemed to stall out but it continued to run, just that the throttle stopped responding to my inputs... anyone answer this? i would accelerate, and it would just stop like it stalled and the engine RPMs would drop and a couple light on the dash would turn on, ABS, etc, and if I hit the gas...NOTHING... but if I waited or down shifted the car would respond to throttle inputs again. Any ideas.

Car has NOLOGY wires, Supersprint exhaust, and Momo wheel, and is lowered with BBS rims. The dash says in has 36,000km. No red lights etc on. According to the BMW dealer its original.

What should I do next to get the max performance gain? Where can I get a strut bar and sway bars and antiroll equipment for my M5? What else should I have done while its at the dealer. This car will be my daily racer and driver, as my 450Hp Rx7 is now not street legal.

I own a performance shop, but we specialize in Jap Imports. I want to start carrying BMW tuners parts, so anyone looking for a Western Canada dealer contact me.

I look forward to everyones replies, thank you in advance.:M5launch:
 

·
Registered
Joined
·
546 Posts
Korman Fast cars, Turner Racing have items you request. Bavauto make a chip that about all ther is for performance You may be able to find some shrick cams. For exhaust ther eis B&B or supersprint if you wnant cat back.
 

·
Registered
Joined
·
1,166 Posts
Hi!
And welcome to the board.
Couple of thoughts concerning the stalling issue: Could be just condensation if the car has been stationary a long time(36000kms means it hasnt been used much), Has it been jet-washed in the engine compartment lately? could be water in the spark plug holes(this has happened to me once, identical symptoms). Bad grounding?
Old ignition parts with corrosion?

Cheers
Sakke
 
1 - 6 of 6 Posts
Top