BMW M5 Forum and M6 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 · (Edited)
When I was in the middle of having my exhaust installed, I was noticing the routing of the EGO sensor wiring under the chassis. The wiring seems standard from where it attaches to the exhaust, running up the chassis, but then I noticed something strange.

The wiring was secured via industrial zip ties to the shifter carrier! :eek: The wiring actually goes up past the propeller shaft, runs into the interior of the car through the rubber shift boot and then to a plug-in connector. This connector then runs back down across the carrier and towards the transmission area and then out of site....



So basically can someone tell me if this is a strange jerry-rigged EGO wiring, or maybe provide some under carriage pictures to compare it to?

Thanks in advance,
Jeff (is confused)
 

·
Registered
Joined
·
20 Posts
The O2 sensor lead should run over towards the driver side (LHD cars) and get routed/covered by a braket that turns and heads towards the front of the car. No zip ties, at least on my '88, and everything is beneath the car.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #3 ·
Thanks for the input.

I replaced the sensor this weekend, and routed it the way it should be routed. I have no idea wtf was with it previously. Considering the 02 sensor I pulled out of the exhaust was the original sensor, this was long overdue. Car runs like a beast now. Drivability, gas mileage, and power have all improved.

:cheers:
 
1 - 3 of 3 Posts
Top