BMW M5 Forum and M6 Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
88 Posts
Discussion Starter #1
I can turn on the system, I can see the orange light come up, I can also talk on my phone (ULF bluetooth) but I can't hear anything on the radio, cassette player or any CD. It's an '01 with DSP.

I took out the radio tuner and the connector had some moisture on it so I think that somehow water got into it (dammit carwash!).

So question is if the radio tuner has gone bad, is it causing the no-audio issue for the cassette and cd players? Is there a way to diagnose the tuner? I can see the radio station and song details on the screen btw.

Also, in-dash and radio tuner fuses are all fine. :)
 

·
Registered
Joined
·
6,632 Posts
If you found moisture in the radio's connector; remove the radio module and clean and thoroughly dry the module (15 minutes in a 210°f oven will work very well). Hopefully, the issues is moisture shorting the audio and cleaning and drying will sort it out. You should probably check the tail light gaskets as this is a common issue which can allow water to enter the trunk and collecting on the radio.
 

·
Registered
Joined
·
88 Posts
Discussion Starter #3
@AGM5, I did what you suggested. The contacts had some oxidation so I also cleaned the contacts and the connector with rubbing alcohol. No change.

Anyone with ideas on how to diagnose this?
 

·
Registered
Joined
·
632 Posts

·
Registered
Joined
·
632 Posts
@SeeSure, tried it. No luck
Probably the solder joints then... if you are handy with a soldering iron there are a few guides kicking around the internet...

I actually sent mine away to guy in here in the UK who charged me £40 to do the work, I found him via e-bay, you could try to see if there is someone in your part of the US?

Once the solder joints go it does take down the radio, tape and CD (It did in my case) and the phone and sat nav carried on working fine.
 

·
Registered
Joined
·
88 Posts
Discussion Starter #7
I can find posts about the dry joints problem, but not exactly sure which joints dry out. Can you link me up?
 

·
Registered
Joined
·
632 Posts

·
Registered
Joined
·
88 Posts
Discussion Starter #9
ok - I finally got around to checking for dry joints, but I can't find any joints that look abnormal.
Also, I should add that my unit is a C43 BM US, and I can't find any links online for dry solder joints for this model.

Does anyone have any other idea? I don't want to spend $200+ on a replacement and find out something else might be bad
 

·
Registered
Joined
·
184 Posts
Mine "looked" alright aswell, i still did a resolder on all of the joints and over 1 year problem free now!
My issues were that my radio would cut out from time to time.
 

·
Registered
Joined
·
5,881 Posts
Does anyone have any other idea? I don't want to spend $200+ on a replacement and find out something else might be bad
I have a known to be good C43 radio for $85 shipped if you want to give it a go.
 
1 - 12 of 12 Posts
Top