BMW M5 Forum and M6 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
148 Posts
Discussion Starter #1
This morning while I was driving to work I noticed the Nav screen went completely blank. The radio was still working, and I could see the on board computer functions on the instrument cluster. I pulled over and tried to "reboot" by shutting the car off and back on. I didn't have time to wait as I was already a bit late. I knew the screen was on because as I shut off the car I saw the "liquid" in the LCD. It was on but just completely black. Rebooting didn't help. I called dealer and scheduled an appointment for next week.

After work today I started the car and the nav screen was back! Anyone had this happen before? And how could I prove this to the dealer? I'm runnning software v22 on my 2001 M5.

Thanks.
 

·
Registered
Joined
·
37 Posts
It's happened a couple of times to me. I also have v22 but it may have happened before I upgraded, I can't remember. In my case it came back on when I stopped and restarted the car.

KJJ said:
This morning while I was driving to work I noticed the Nav screen went completely blank. The radio was still working, and I could see the on board computer functions on the instrument cluster. I pulled over and tried to "reboot" by shutting the car off and back on. I didn't have time to wait as I was already a bit late. I knew the screen was on because as I shut off the car I saw the "liquid" in the LCD. It was on but just completely black. Rebooting didn't help. I called dealer and scheduled an appointment for next week.

After work today I started the car and the nav screen was back! Anyone had this happen before? And how could I prove this to the dealer? I'm runnning software v22 on my 2001 M5.

Thanks.
 

·
Registered
Joined
·
148 Posts
Discussion Starter #3
I've seen the nav screen reboot itself while I was driving. It would go blank, then the "BMW" logo comes up, and then back to the normal screen. It's probably a software issue. Maybe I should revert back to an earlier version. We'll see what the dealer says next week.
 

·
Registered
Joined
·
76 Posts
I had going "blank" problem with MKIII, when software update didn't cure it, the dealer replaced the NAV unit, it was faulty. If it stalls and reboots itslef repetitively, it should be replaced under warranty.
 
1 - 4 of 4 Posts
Top