BMW M5 Forum and M6 Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
235 Posts
Discussion Starter · #1 ·
Last summer the Nav display started to lock up. It seemed to be heat related as it only happened in the afternoon on the way driving home. A friend of mine recommended updating to the latest Nav OS (29.1 at the time I believe) as it might fix the problem. I must say that after driving it all winter that I completely forgot about the proposed fix, or even that the problem existed.

Well spring time and warm days in the North East have brought out the lil demons ugly head again. The weird thing is that all the normal functions of the radio still work (bluetooth, sirius, radio) it's just the display that locks up.

When I spoke with the BMW SA last year in passing she said that the electronics are not covered in the extended warranty of a CPO and that I'd be on my own with regards to a fix.

So I pose the question to the masses. Has anyone had similar problems of just the display locking up (seemingly when it was hot oustide), to clear later on (once again, when it seems like it cooled down) ? The event does not happen all the time which makes trouble shooting it that much more difficult. I will be trying the updated OS tonight to see if that helps anything, but I'd like to know if I'm gonna be stuck having to get a new nav unit or even display :(
 

·
Registered
Joined
·
12,987 Posts
Last summer the Nav display started to lock up. It seemed to be heat related as it only happened in the afternoon on the way driving home. A friend of mine recommended updating to the latest Nav OS (29.1 at the time I believe) as it might fix the problem. I must say that after driving it all winter that I completely forgot about the proposed fix, or even that the problem existed.

Well spring time and warm days in the North East have brought out the lil demons ugly head again. The weird thing is that all the normal functions of the radio still work (bluetooth, sirius, radio) it's just the display that locks up.

When I spoke with the BMW SA last year in passing she said that the electronics are not covered in the extended warranty of a CPO and that I'd be on my own with regards to a fix.

So I pose the question to the masses. Has anyone had similar problems of just the display locking up (seemingly when it was hot oustide), to clear later on (once again, when it seems like it cooled down) ? The event does not happen all the time which makes trouble shooting it that much more difficult. I will be trying the updated OS tonight to see if that helps anything, but I'd like to know if I'm gonna be stuck having to get a new nav unit or even display :(
If you are going to replace something anyway, you might try Martin at Bimmernav. He carries a variety of stuff for our cars.

If I had to guess, your display is fine, it is the module in the trunk that is heating up and cutting out. Intermittant is hard to find. I note you have aux input. Sometimes, the system is senstive to add on's. Have your tried disconnecting the aux input at the source to see if it makes any difference?

Regards,
Jerry
 

·
Registered
Joined
·
235 Posts
Discussion Starter · #3 ·
The aux/sirius install was a couple of years ago. The freezing thing was just recently noticed.
 

·
Registered
Joined
·
3,184 Posts
There is a fan in the back of the Nav unit in the trunk, it's not uncommon for them to fail which then causes the Nav to overheat.

If you take eject the Nav disk when it's locking up is it hot? If not is it dirty (or a copy)?
 

·
Registered
Joined
·
235 Posts
Discussion Starter · #5 ·
It is indeed a copy .. but I have been running copies for a while now, and this is not a new one. The fact that it is only happening in the summer time leads me to believe it is more heat related than not, I'll take a peak at the fan this afternoon when I finally swap my tires (stupid temp swings in the north east and I have my snow tires on until almost may this year :( )
 

·
Registered
Joined
·
207 Posts
This has happened to me as well.

A copy of the NAV disk could cause problems if the media is of average or low quality. If you're using off brand or no-name media, you might want to try a high quality media (Verbatim, TDK, etc.) to see if that fixes the problem.

After I switched to Verbatim DVD-R, the problems went away and it works fine now.
 

·
Registered
Joined
·
12,398 Posts
Heat lock is a KNOWN problem with all navs, mk4 included.

I burned up two under warranty. Particularly bad with a full trunk of crap in the 100+F Calif summers.

The lock up CAN be exacerbated with burned data, but the root cause is heat.

a
 

·
Registered
Joined
·
2,203 Posts
there is a post in the deep recesses of this board somewhere, a 120mm PC case fan was installed into the compartment.
 

·
Registered
Joined
·
235 Posts
Discussion Starter · #10 ·
I'll try an old map dvd (original) to see if that makes it better, and possibly get a reburnt copy of the new map dvd.

I'll search for the fan mod. Thanks all who responded.
 
1 - 10 of 10 Posts
Top