BMW M5 Forum and M6 Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
2,881 Posts
Discussion Starter #1
While my car was on the lift I snapped some pics of my springs... I have a clicking noise when I go up inclines... is this the problem or are these H&R spings normal? My installer told me they are installed properly.... please help.
 

Attachments

·
Registered
Joined
·
4,248 Posts
This is the most annoying issue... Gosh darn clicking when left front has load on it. No noise when hitting bumps in straight lines, only when turning. So odd... we will get to the bottom of it Bernie.
 

·
Registered
Joined
·
4,101 Posts
Normal indeed. Mine has always clicked a little when I am performing slow maneuvers.

Bernie,

Live with it! Just kidding.

'Rocket
 

·
Registered
Joined
·
1,010 Posts
You should not be getting any noise. I've had a couple of noises since I've had suspension work and I've always got rid of it.

You just need to make sure that all the bolts are tight.
 

·
Registered
Joined
·
2,881 Posts
Discussion Starter #9
You should not be getting any noise. I've had a couple of noises since I've had suspension work and I've always got rid of it.

You just need to make sure that all the bolts are tight.
easier said than done my friend, the installer checked everything under there and then the head foreman at my dealer checked every piece of suspension and tightened every bolt and noise is still there... :(
 

·
Registered
Joined
·
4,248 Posts
I think its a Gremlin living under there personally. We will find out within the next two weeks Bernie.
 

·
Registered
Joined
·
1,010 Posts
easier said than done my friend, the installer checked everything under there and then the head foreman at my dealer checked every piece of suspension and tightened every bolt and noise is still there... :(
First time it happen I asked the dealer to check and they found nothing wrong.

Took it back to the place that did the install and they found it.

I had a very slight sound that I could only hear with the stereo off at slow speed over small bumbs when turning, that I guess sounds like a click, but I would describe it more like a very slight creak.
This was caused by just one bolt.

At the bottom of the strut, there are 2 bolts on the left front:
One is the pinch bolt that holds the strut in place
The other I think holds the bracket for the headlight control thingy, it was this nut, it was not loose, but it was not quite as tight as the others, after tightening it, my car was perfect.

I should be able to get a pic if you want.
 

·
Registered
Joined
·
4,248 Posts
NB:

No need for the pic as I know exactly what part you are talking about. Thank you for your assistance. We will take a look at that when the car comes back up here.
 

·
Registered
Joined
·
427 Posts
I don't think mine touch.
 

·
Registered
Joined
·
73 Posts
I believe touching at the "ends" of the springs is normal- as progressive springs will compress the first few coils under load. the more weight and pressure applied, the spring's rate increases.
 
1 - 14 of 14 Posts
Top