BMW M5 Forum and M6 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
259 Posts
Discussion Starter #1
I have several electrical issues that are bugging me and I wonder if anyone here has had the same:

1. Passenger side mirror doesnt always tilt down, or it tilts and doesnt come back up.
2. Intermittent A/C problem, fan doesnt blow about 1 out of 10 times or so I start the car.
3. Alarm system goes off on its own, seems to be when its 90+ temperature. I've tried disabling the tilt/motion sensor but that doesnt work either.
4. the dreaded missing pixels in the display under the speedo/tacho


any insight would be appreciated.
 

·
Registered
Joined
·
71 Posts
I had the alarm problem on a different car. Many moons ago, I owned a 92 Acura Vigor that wouldn't start and/or the alarm would go off on very hot days. The problem was rare enough for me not to bother to fix it (junker anyways) so I guess I can't offer any insight with the M5. You probably already know this, but make sure your driver/passenger mirror switch is to the left when using reverse, the passenger mirror will not tilt downwards when that toggle is to the right. Hope you get it worked out.
 

·
Registered
Joined
·
723 Posts
1) not sure
2) this is most likely due to the final stage resistor. do a search for more info
3) Check the condition of your battery. As the battery starts going bad, it will sometimes set off the alarm
4) After warantee expires, some have been replaced by BMW NA as goodwill. You can also send your instrument cluster to www.vdorepair.com They will fix it for a reasonable fee, and apparently improve the design of a cable which causes this. I have not used their services, but they seem to have a good reputation in the roadfly forums.
 

·
Registered
Joined
·
100 Posts
1) the mirror not coming up happened to me too a few times, normally fixed by putting it in reverse and out again, needed to adjust it with the controls one time to get it back up. It always went down in the first place though.
2) nope
3) happened once
4) had it replaced under warranty

This is on a 2001 which I now own for about 4 months and which had been standing still at the dealer for half a year before that. There were more of these little faults in the car but most have already been fixed under warranty.
 

·
Registered
Joined
·
4,082 Posts
As stated above, your a/c blower issues are almost certainly caused by a faulty final stage resistor, which is a known problem with BMWs. Fortunately, this can be replaced in 15 minutes by your dealer. There is even a link on this board to a 540 website which shows how you can replace it yourself.
 

·
Registered
Joined
·
1,041 Posts
My tilting mirror on my 2000 has only worked intermittently since new, but it is such a silly feature that it doesn't bother me, and it never occurred to me to get it fixed under warranty.

A friend of mine had his odometer pixel problem fixed for free on his 540i this year at a dealers even though the car is 7 years old and has 150k on it. Ask BMW about it as I think it is about $800.

Steve
 

·
Registered
Joined
·
96 Posts
I thought I had a tilting mirror problem but then realised that once set up, the passenger side mirror will only dip when the drivers door mirror is selected on the door panel slider switch.

To set up, select passenger side, set normal position, then engage reverse, set reverse position - once done, move slider to select drivers door mirror - dipping has worked ever since I realised.

Maybe not your problem but thought it worth mentioning what might be the obvious.
 

·
Moderator
Joined
·
10,456 Posts
billrM5 said:
I have several electrical issues that are bugging me and I wonder if anyone here has had the same:

1. Passenger side mirror doesnt always tilt down, or it tilts and doesnt come back up.
2. Intermittent A/C problem, fan doesnt blow about 1 out of 10 times or so I start the car.
3. Alarm system goes off on its own, seems to be when its 90+ temperature. I've tried disabling the tilt/motion sensor but that doesnt work either.
4. the dreaded missing pixels in the display under the speedo/tacho


any insight would be appreciated.
My car does #1 also, i just leave the mirror switch to the drivers side, i think, to deactivate this feature. There is probably a fix for it.

2. sounds like FSU, like others have said.
3 not happened
4 "they all do that" and are generally covered as a warranty item, even after expriation.
Mike
 
1 - 9 of 9 Posts
Top