BMW M5 Forum and M6 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter #1
Hello all.

I have a 2001 M5 with the Mk3 Nav system. After reading a TON of threads about upgrading the OS, I decided to go from v21 to the latest I could find v24_1. I d'loaded the image from a link on X5world.com and burned the CD image. I followed the instructions on the site and proceeded to 'upgrade' the OS. I should have waited and had my dealer do it, but seeing how esy people were saying it was, I did it anyways.

Well, after waiting 15 minutes, the Nav System spit out the cd I burned and the screen went blank. I popped the Map CD back in, but the menu screen did not come back. The system then went into loops of spitting the CD out and sucking it back in and trying to read it.

Now, I'm stuck with a no nav system. :crying:The radio works, but it turns off after 5 minutes or so. I've unplugged the battery for 30 minutes to see if I could resurrect, but no dice. Pulled fuses with the same result.

So, any ideas on how to force a reset or should I bite the bullet and take it to the dealer? Or upgrade to Mk4?:confused3

Thanks!
 

·
Registered
Joined
·
590 Posts
volcan96 said:
Hello all.

I have a 2001 M5 with the Mk3 Nav system. After reading a TON of threads about upgrading the OS, I decided to go from v21 to the latest I could find v24_1. I d'loaded the image from a link on X5world.com and burned the CD image. I followed the instructions on the site and proceeded to 'upgrade' the OS. I should have waited and had my dealer do it, but seeing how esy people were saying it was, I did it anyways.

Well, after waiting 15 minutes, the Nav System spit out the cd I burned and the screen went blank. I popped the Map CD back in, but the menu screen did not come back. The system then went into loops of spitting the CD out and sucking it back in and trying to read it.

Now, I'm stuck with a no nav system. :crying:The radio works, but it turns off after 5 minutes or so. I've unplugged the battery for 30 minutes to see if I could resurrect, but no dice. Pulled fuses with the same result.

So, any ideas on how to force a reset or should I bite the bullet and take it to the dealer? Or upgrade to Mk4?:confused3

Thanks!
I thought V24.1 software was for the MK4 DVD player.

Joe
 

·
Registered
Joined
·
2,071 Posts
Correct. V24.1 is for DVD system. Same as the new V25. Download an earlier version and install it. Make sure and burn it at the slowest speed. Everything will be OK.
 

·
Registered
Joined
·
1,410 Posts
Digi said:
Correct. V24.1 is for DVD system. Same as the new V25. Download an earlier version and install it. Make sure and burn it at the slowest speed. Everything will be OK.
I have a MK3 with v24.1. I did the upgrade a few months ago, but with the EXACT complications because I used cheap discs.

Go to my previous post #41 for more info:
http://www.m5board.com/vbulletin/showthread.php?t=50066&page=2

Good luck.
 

·
Registered
Joined
·
71 Posts
Discussion Starter #6
FIXED!!!!!!

Guys, thanks for the info! I went back downgraded the firmware to v22 and that worked like a charm.

After reading your posts, I went back and reviewed my notes from last night and saw that I misread what was written on the X5 board. I thought that my system was at sw v21, but actually it was at v16!grrrrrrrI feel so stupid.

I ended up having to use the CD key to get it to work, but that was easy. Anyway, I ended up learning a few things in addition to getting an updated interface.

Lessons learned:
1) Most important: Don't start research at 1030pm and then try to do the upgrade around midnight unless you are wide awake.

2) Read and re-read instructions.

3) Don't be afraid to ask questions on this board.

4) the Nav system firmware is downgradeable if you manage to screw it up like yours truly.

5) CCD and Nero files can be burned on a Mac and work fine to do this upgrade if you burn at 1X and use Roxio Toast.

Thanks!!!!
 
1 - 6 of 6 Posts
Top