BMW M5 Forum and M6 Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
376 Posts
Discussion Starter #1
Driving down the road today, the idrive went blank(shut off), BMW appeared on the screen, i'm assuming it tried to reboot, idrive came back on and I heard a click and off it went again, this kept repeating several times then nothing? I'm assuming a short somewhere hence the click.
Also the driver mirror for some reason over rotates and so I have to twist it to where it supposed to be, sunroof makes a loud noise when it closes. Despite that, I still enjoy the ///M! We buy high tech I guess it just comes with the territory.......:dunno:
 

·
Moderator Emeritus
Joined
·
915 Posts
Had this problem several times, generally an indication that the iDrive (CCC) is about to fail. My dealer could never replicate the problem so I took a video to show them:

Myself and several others on the board have started threads about this, you could do with reading the info in some of these threads prior to going to the dealer:
http://www.m5board.com/vbulletin/showthread.php?t=101042&highlight=ccc+failure
http://www.m5board.com/vbulletin/showthread.php?t=107997&highlight=ccc+failure
http://www.m5board.com/vbulletin/showthread.php?t=96858&highlight=ccc+failure
http://www.m5board.com/vbulletin/showthread.php?t=113867&highlight=ccc+failure

Should be a warranty issue, along with the mirror and sunroof.
 

·
Registered
Joined
·
376 Posts
Discussion Starter #3
Thanks scoopz, the info. was very helpful. I read the threads and that's exactly the problem i'm having, even getting the SOS malfunction. Making an appointment today. This board is fantastic!:M5thumbs:
 

·
Registered
Joined
·
218 Posts
Dropped my car off at the shop for the SOS/Audio issue today as well. The SA was very nice, but did ask a lot about the phone I am pairing with the car. In my case, it is a BB 8300. I don't know where this is headed. 6500 miles, and this has only happened once. I'll be waiting to hear back.
 

·
Registered
Joined
·
1,513 Posts
Certainly sounds like a CCC failure. Mine happened a little over a year ago. Annoying, but essentially harmless, unlike the SMG cogs, fuel pumps (see my saga within my CCC thread) or Vanos hose problems.
 

·
Registered
Joined
·
1,428 Posts
Unless an error code is stored, stealership may try a software update first. CCC replacement is the only sure method to fix the problem.

Make sure you remove the Nav DVD before they replace CCC, unless you want a newer disc. :blink:
 

·
Registered
Joined
·
915 Posts
the same EXACT problem was happening to me. mirror and idrive. they replaced my whole idrive computer.
 

·
Registered
Joined
·
125 Posts
It happened to me for the first, and hopefully last, time yesterday. However, mine locked up as to the song that was playing and the nav, and then it went to the BMW screen.
 

·
Registered
Joined
·
376 Posts
Discussion Starter #9
I'm assuming with all the technology in the car that when it happens it is recorded and when they run the diagnostic it tells them of the failure. Some days it shuts off or won't come on, then another drive it works, but i'm noticing that when I start the car the BMW screen slowly comes on.
I did do the volume knob/eject buttons to reboot and it sometimes works. I made an appointment for next week. Just hoping that they can read the problem in the computer and it doesn't have to do it in front of them.
 

·
Registered
Joined
·
1,428 Posts
I'm assuming with all the technology in the car that when it happens it is recorded and when they run the diagnostic it tells them of the failure.
Unfortunately CPUs only monitor some events and not others. Don't let the stealership avoid fixing the problem if nothing shows up.
 

·
Registered
Joined
·
737 Posts
It happened to me for the first, and hopefully last, time yesterday. However, mine locked up as to the song that was playing and the nav, and then it went to the BMW screen.
Computers suck... yet we rely on them for so much. Good luck, I hope this does not happen to you again. :crying2:
 

·
Registered
Joined
·
312 Posts
Never had the idrive problem (yet) but definetly had sunroof issue. Use to think it was shut then a minute later BANG it shut. Dealer fixed never told exact problem but seemed pretty aware like they've seen it or should I say heard it before. :3:
 

·
Registered
Joined
·
1,471 Posts
Dropped my car off at the shop for the SOS/Audio issue today as well. The SA was very nice, but did ask a lot about the phone I am pairing with the car. In my case, it is a BB 8300. I don't know where this is headed. 6500 miles, and this has only happened once. I'll be waiting to hear back.
The Bluetooth issue is not far fetched. I've read on another respectable board that this was *sometimes* the cause. As my I-Drive screen did not boot up every 20 starts or so, I actually deleted pairing and re-paired my phone. It only happens once every 200 start ups or so.

There is a TIS on this (The following was copied from cobradav at the forums.e60.net board)

Frequently reported issue in BMW TIS

SI B 84 16 07
Communication Systems September 2007
Technical Service

designates changes to this revision

SUBJECT
Erroneous SOS Inactive Warning Message


MODEL
E60, E61 (5 Series) with SA609 (Navigation) up to 8/07 production

E63, E64 (6 Series) up to 8/07 production

E70 (X5) vehicles equipped with ZPP ( Premium Package) or SA639 (BMW Assist) and Navigation

(SA609) up to 9/07 production

E90, E91, E92, E93 (3 Series) vehicles equipped with ZPP (Premium Package) or SA639 (BMW Assist) up to 8/07 production


SITUATION
An erroneous check control message stating the 'SOS inactive' is displayed. The BMW Assist™ system functions normally.

KOMBI Fault Code: A554 (Alive Phone) stored in fault memory when using DIS V51 or higher.

CAUSE
Software error in the RAD2 or CCC.

or

SI B 84 17 07
Communication Systems September 2007
Technical Service

This Service Information bulletin supersedes S.I. B84 17 07 dated August 2007.

designates changes to this revision

SUBJECT
SOS Inactive Warning Message, No Communication with TCU


MODEL
E60, E61 (5 Series)

E63, E64 (6 Series)

E65, E66 (7 Series)

E70 (X5) vehicles equipped with ZPP (Premium Package) or SA639 (BMW Assist)

E90, E91, E92, E93 (3 Series) vehicles equipped with ZPP (Premium Package) or SA639 (BMW Assist)


SITUATION
A check control message stating the 'SOS inactive' is displayed.

The Telematics Control Unit (TCU) is NOT identified when performing a short test using the DISplus or GT1.

If the SOS button is pressed the call connects but the radio is not muted. The BMW Assist™ phone calls audio comes from the emergency speaker.

Bluetooth: An approved Bluetooth® enable handset which previously worked no longer connects to the vehicle. The Bluetooth menus for pairing a device to the vehicle are unavailable.

RAD2 vehicles: The BMW Assist icon and phone icon are missing from the Radio display.

CCC vehicles: Enable Services is grayed out.

CAUSE

TCU Hardware failure.

MOST-bus communication issue.

Incompatible handset paired to the vehicle.

and probably more. TCUs can be "deactivated" accidently during a "reactivation" process after a software upgrade. This probably is not true in your case, however.
 
1 - 13 of 13 Posts
Top