BMW M5 Forum and M6 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1 (Edited)
Need some help guys.. i'm at a loss :dunno:


Today was wet and rainy outside... so I decided to have a little Fun with the beast.. I took her for a few Slow speed power slides (approx 6-7)

then drove home..

on the road.. I noticed the SES/CEL light came on...

now the car wont hold an Idle... :sad2:


the car is acting like it has a HUGE vacuume leak..

the idle is constantly hunting surging searching..

and will regularly shut off as well...

I'm constantly left Heel and toe'ing at Traffic lights... the car stalls very easily...



I'm fairly certain it's a Vacuume leak.. but i'm not sure..

it SOUNDS like there is air rushing/leaking in/near/under the front of the intake plenum...

I took the plenum off exposing everything underneath.. i couldn't see any apparent split or open hoses...

What are the chances of the IACV going bad? is there anyway to check it?

I put it all back together and retightened it.. and still same problem :(


I don't have a peake to pull the codes...

would a bad IACV throw a code? or is it cuz of a misfire or something..


the strange thing is.. on the highway and what not.. the car still pulls fine and has power..

if i hold my foot on the gas.. I can make the car hold an idle at ~900 rpm.. and the engine doesn't shudder or buck or hesitate.. it's steady... but when i let go.. it starts hunting when it tries to idle at it's "natural" 630rpm...


MAF's are fine.. I tested them last month.. and they were spot on...



anyone have similar problems? or any ideas of where i should start?.. looks like i have to pull it all apart again as well..


i'm Hoping i wont have to pay $400 for a new IACV...
 

·
Registered
Joined
·
36 Posts
Discussion Starter #3
what is the MIL?

my check engine light is on... the one in the lower left side of the gauge cluster..

when i press the button.. it says Check Control OK

how does that work? :S
 

·
Registered
Joined
·
36 Posts
Discussion Starter #4
Just wanted to update..

I took the car and pulled the error codes..

the code is showing o2 sensors Pre cat.. both 1 and 2...

seems like a secondary side effect to the problem tho.. not the actual cause of it..
 

·
Registered
Joined
·
36 Posts
Discussion Starter #6
well the good news.. I was right..

it was a cracked hose under the plenum Leaking air.. nothing to do with the MAF's

The Bad news..

the workshop said both my front control arm bushings and 3 rear Diff bushings are shot and need to be replaced.. :(

she'll be outta commission for another 3 days..

i'm getting M5 withdrawls.. i need my fix!
 

·
Registered
Joined
·
924 Posts
Seems to be a rash of vacuum leaks popping up on E39 M5's now. From now on first place I look if there is a problrm.
 
1 - 7 of 7 Posts
Top